Eh... Help? Invalid color format?

Well, this is not what I wanted to happen at all… This has happened to every other source game, and this was the ONLY one that had hope… until now…

http://puu.sh/7KsDl/51015140e0.jpg

http://puu.sh/7KpXn/8b1ccaa51b.jpg

http://puu.sh/7KpY3/c0ea10e06c.jpg

http://puu.sh/7KpUT/0f308fffc7.jpg

Don’t use DirectX 8. If you can’t use DirectX 9, upgrade.

I don’t get it though, it worked fine until I recently re-installed my Gmod
It might have something to do with me setting the -dxlevel to 90?

[editline]26th March 2014[/editline]

It’s ok, I fixed it independently… :confused:

How did you solve it for other users if they have the same problem?