Emitter tool causing Scripting error

This happened when I was making my New Gmod Machinima for Youtube (Not the one involving a Spiral Mountain map) http://tinypic.com/r/ictu0z/8 Does anyone know a solution to this error? I tried removing a few addons I didn’t need, but it still gives me this scripting error. Any help please?

Open the console and paste the actual error.

[ERROR] gamemodes/sandbox/entities/weapons/gmod_tool/stools/emitter.lua:113: attempt to call method ‘SetScale’ (a nil value)

  1. MakeEmitter - gamemodes/sandbox/entities/weapons/gmod_tool/stools/emitter.lua:113
  2. LeftClick - gamemodes/sandbox/entities/weapons/gmod_tool/stools/emitter.lua:69
    3. unknown - gamemodes/sandbox/entities/weapons/gmod_tool/shared.lua:252

Remove addon called something like “Extra emitters” or something like that, it overrides default file, which is not updated in the mod.

It worked. :smiley: Thanks.