Engine error

http://img504.imageshack.us/img504/7003/picture1tav.png

ok…
um
right when you start up GMOD type mat_dxlevel 80 in console

You might not have to. Did you get the error while playing, or when you boot up?

I get this error as soon as I play on cs_militia. It’s annoying as hell.

I get it every time I load any map if I have too many addons installed. and by too many I mean more than 6. EDIT: on my main computer, this happens only every now and then after I load too many props. On this it happens every map. I think it is a matter of ram. I have 1gb on this. 4gb on my main, which I am planning to expand to 8 eventually.

Not a matter of ram, I play on 3gb… what are your general pc specs? cpu and gpu

Its old.




Hardware Overview:

  Model Name:	iMac
  Model Identifier:	iMac5,1
  Processor Name:	Intel Core 2 Duo
  Processor Speed:	2.16 GHz
  Number Of Processors:	1
  Total Number Of Cores:	2
  L2 Cache (per processor):	4 MB
  Memory:	1 GB
  Bus Speed:	667 MHz
  Boot ROM Version:	IM51.0090.B09
  SMC Version:	1.9f4
  Serial Number:	**********

BANK 0/DIMM0:

  Size:	512 MB
  Type:	DDR2 SDRAM
  Speed:	667 MHz
  Status:	OK

BANK 1/DIMM1:

  Size:	512 MB
  Type:	DDR2 SDRAM
  Speed:	667 MHz
  Status:	OK


ATI Radeon X1600:

  Chipset Model:	ATY,RadeonX1600
  Type:	Display
  Bus:	PCIe
  PCIe Lane Width:	x16
  VRAM (Total):	128 MB
  Vendor:	ATI (0x1002)
  Device ID:	0x71c5
  Revision ID:	0x0000
  ROM Revision:	113-xxxxxx-139
  EFI Driver Version:	01.00.139
  Displays:
iMac:
  Display Type:	LCD
  Resolution:	1680 x 1050
  Depth:	32-bit Color
  Built-In:	Yes
  Core Image:	Hardware Accelerated
  Main Display:	Yes
  Mirror:	Off
  Online:	Yes
  Quartz Extreme:	Supported
Display Connector:
  Status:	No display connected


Its running Gmod in Crossover Games.

Funny thing is, with gmod running, Crossover uses a combined 10 Gb or virtual memory.

This is my backup machine, btw.

I wish I owned a Mac Pro :frowning:

Yea even using things like crossover games doesn’t mean it will work.

Actually it does mean it will work. Its the same as dual booting windows without paying $100 dollars for something I don’t want. This is not a Mac specific error. I seem to have fixed it though by tricking the game into thinking I have 256mb of Vram with regedit

It won’t always work, it’s emulation.

No it is not. Emulation would be emulating another TYPE of processor. CGames, in essence, is Wine but better. More refined with a better GUI than free Wine. This computer has an INTEL processor which is the same a PC uses, so windows will run just fine. Wine, in several forms, also works. This allows Mac users to run Windows games at near native speed, without having to own Windows or deal with the OS. I am not here to get into a flame war.

It still needs to emulate Windows API.

I concede that you may be correct on that bit.