Entering Chat Bug Crash - RUST NOT RESPONDING - who still has this issue?

Okay, so I know this does not affect all of us, but it has to be affecting many of us still. It’s been going on since devblog update 91 I believe (the unity upgrade before this one, 5.4.2?). I’m just trying to bring this bug up front a bit more, as it’s still an issue. So apologies, but trying to raise bug awareness lol.

**BUG DESCRIPTION : **
Upon Entering chat / opening chat window, rust client will immediately freeze. There is no crash report, or crash log. Game will NOT RESPOND, and you are forced to close it either through task manager or, closing the rust window.

A semi-helpful fix was just disabling the chat window in the general options of the game. However, the game will still proceed to crash at random intervals (no set times, I experimented with it numerous times. Could be 5 mins inside a server, could be an hour). Once again, no crash log. Just the game client not responding and requiring a force close through task manager or closing the window.

BUG TEMP FIX
The only known temp fix for this bug is to use this series of strings - now not all of this matters, and the most important factor is the -force-opengl command. This is what I have as my launch options currently.

-cpuCount= 2 exThreads=2 -high -maxMem=16384 -malloc=system -force-feature-level-11-0 -winxp -popupwindow -nologs -force-opengl

By adding -force-opengl I am able to run the game, but I average 15 FPS especially on a crowded server. This doesn’t matter what graphics settings I have it at. I can have max settings, and I can have lowest settings. It still averages around 15 fps.

Without -force-opengl I get around 30 FPS. Much more playable, but sure not 60-80 fps like some of you get. But a huge difference from 15 fps.

Here are my COMP SPECS : Yes, I know it’s not a power house.

PROCESSOR : AMD A4-6300 3.7 GHZ DUAL
Int. Graphics : AMD RADEON HD 8370D ( i do not use this )
GRAPHICS CARD : NVIDIA GeForce GT 730 2 GB
RAM : 16 GB DDR3
HD : 1 TB HDD
O/s : Windows 8.1

If anyone else has this issue, please post your specs. Trying to find a common ground.

Thanks all.

Not to say this deters me from playing a great game. Still love it at 15 fps, but would love it even better back at my good ol 30 lol

Mind trying this just for giggles, and see if it sticks?

POSSIBLE FIX:

DELETE the registry tree HKEY_CURRENT_USER\SOFTWARE\Facepunch Studios LTD

One can use their favorite registry editor, to do the dirty deed, or you can copy the text below and save it as a .reg file and then run it.



    
    ;=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
    ;RemoveFacepunch.reg
    ;=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
    ; Small Registry deletion to remove 
    ; HKEY_CURRENT_USER\SOFTWARE\Facepunch Studios LTD
    ;
    Windows Registry Editor Version 5.00
    [-HKEY_CURRENT_USER\SOFTWARE\Facepunch Studios LTD]
    ;=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
    ;END of RemoveFacepunch.reg
    ;=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-


** My Chat UI issue that the above resolved, did not freeze the game up, but I was unable to send messages unless I used the console window, and I had to escape out of the “Chat.Open” bind as pressing enter while this “Green Bar” was displayed did nothing. ** I am wondering if doing the same will fix your issues as well?

I’ll give it a whirl and let you know

Did the possible fix work? If so reply