Environment Mask Maps Wont Show Up

Hi, I applied Environment Mask Maps to my model that show up fine in Model Viewer but don’t appear to show up in Garrysmod.

Shader


"VertexlitGeneric"
{
	"$basetexture" "models/banshee/banshee"
	//"$bumpmap" "models/banshee/banshee_bump"
	//Above is halo 2 Bump Map Turned off because this is halo 1 shee
	//Turn it on if you think it looks better :P but i think that breaks the specular..
	"$detail" "models/banshee/banshee_detail"
	"$detailscale" 12
	"$envmap" "models/banshee/banshee_env"
	"$envmapmask" "models/banshee/banshee_spec"
	"$envmaptint" [1,1,1]
	"$selfillum" 1
	"$selfillummask" "models/banshee/banshee_illum"
	"$surfaceprop" "Metal"
	"$surfaceprop2" "Metal"
}



In Model Viewer (working)

http://img180.imageshack.us/img180/1434/perfection.png


In Gmod (not Working) 

http://a.imageshack.us/img535/738/rpc18v10001.jpg

Immediate trouble-shooting questions I feel compelled to ask are:

Did you put all of updated the materials/models into Gmod and you’re not accidentally using old content?

Do you have specularity enabled in Gmod? (mat_specular 1) (not the same as phong)

Have you tried the model on different maps in case it’s just bad lighting?

I know it’s not quite what you want to hear, but have you thought of using phong instead and using similar effects to what the hunter uses, only not green.

Just recentlly tried all of those, in gm_construct there the same.

This is a common problem with the latest source engine. envmapmask seems to be broken, all you need to do is either put that mask in the alpha of your diffuse texture or your normalmap, then add the specific vmt command.