$envmap Help

Hey,

I made a neato custom skin with all the right attributes, but to spice it up a little I figured “Hey, I should add $envmap to the vmt!” Great idea! But I get an incredibly thick, wet looking watery effect that makes the texture look gray and boring. Anyone know if there is a “$parameter” that will fix this?

-Thanks

If you haven’t already checked the article on the Wiki, I’d do so: http://developer.valvesoftware.com/wiki/$envmap.

Also, odds are you either have a bumpmap with no alpha channel, or a very mild alpha channel that’s causing the cubemap shader to go haywire (See:http://img684.imageshack.us/img684/8153/gmconstruct0039.jpg). That, or, you’ll want to make good use of the “$envmaptint” “[ R G B]” parameter (possibly both). The article should have more info, but those would be the first things I’d try. Fortunately, the Source engine’s material system is logical and easy to troubleshoot once you know what to look for.

Are you using an envmap mask?

I am not using an envmap mask, I didn’t think that I would need to do such a thing for a simple reflection. Also when I set $envmaptint to “50 50 20” it just showed up plaing white. This is going nuts. Also I have a pretty simple bumpmap.