EP1 GCF Error

Hey facepunch has any one been having trouble extracting materials from the EP1 GCF file the GCF let’s me extract the models but it wont let me extract the materials I get the error.


Error writing C:\Users\#######\########\materials\Concrete\concretefloor028a.vtf (Error: Unexpected end of GCF stream (0 B of 174968 B).  Has the GCF file been completely acquired?)

I have tried Verify Integrity but that did nothing I tried loading the map into the SDK EP1 Config but most of the materials are missing because they are custom textures.

Any one know how to fix this O! also I have tried reinstalling and that did not work :frowning:

If they are custom textures just place them in the episode 1 folder. I wouldn’t suggest trying to compile it in the episode 1 engine if you made it in a different version, can lead to loads of errors.

[quote=“ciyborg_delta1, post:1, topic:102141”]

This happens when you try and grab a texture from another game. You can fix this by opening another gcf, I believe that one is from source engine shared material, or 2007 shared materials gcfs

dam I have asked 3 people I know to try and they are getting the errors too I think its a big conspiracy from Valve :rolleyes:

O! I see, done it :smile:

So if anyone else gets the same problem where the file is grayed out in GCFScape just right click on the file and select properties then look at location that will tell you what GCF will give you that file e.g.

I need the file door01a_skin15.vtf from the episode 1 shared.gcf but its grayed out just right click select Properties and look at Location: root\episodic\materials\models\props so this file is located in the episodic.gcf but don’t forget that vtf might be in another file but the vmt will be in episode 1 shared.gcf