EP2 map in Gmod issue.

Hello,

I have a problem with last map from HL2: EP2. When I am supposed to launch the rocket, dr. Kleiner won’t open the button cover, so I can’t launch it.
Is there any way to bypass it? I need to film the last scene, but I just can’t get access to it.

Thanks in advance.

http://imgur.com/OUYj7l.jpg

I think if you extract all the character animations from the Episode 2 GCF and place them in the correct folders in Gmod, they will work.

OK thanks, I will try it. But I think GMod already has access to animations, because NPCs are moving and speaking like in game, except one animation.

Anyway, will try it.

Some animations don’t work for some reason.

Like how on the Griggs and Sheckley map the vort goes into the t-pose.

Ah, it’s not working.

But I found interesting entry in console:


CSceneEntity alyx :"alyx" unable to find gesture "A_g_leftsweepoutbig"
**kleiner: unknown scripted sequence "ss_launch_button"**
Direct precache of ep_02.al_launch_allyours

so it has something to do with scripted sequences.

//Edit: copied “scripts” folder, still doesn’t work. It looks like I need to find scripted sequences files, wherever they are.

//Edit2: Extracted ALL GCFs into clean garrysmod folder. Worked. Yipee.

I’d rather place the model and animation files in the maps .BSP files, you will need Pakrat for that

Good to know, thanks.

If i try to play ep2 maps on gmod, the characters go nuts! example: you know the part before the crouch adventure to destroy auto turret? When i start that one, the rebel is letting me and alyx into the garage from backdoor but then the rebel dies and alyx walks to wall and dies and the welder dies when i push his bottle down or hit the car! any advises?

[editline]08:03PM[/editline]

Good thing is that the npcs and props and other stuff do work… oh! theres one more thing! My jalopy works perfectly on other things but no sounds! Only sounds are crashing sounds and engine turning off sound!