Episode 2 not loading for GMOD

I am playing a singleplayer map that needs Half Life 2 Episode 2. I HAVE run Episode 2, but I still cant see EP2 Content. I will post what it is saying in the console.


Mounting hl2.. OK
Mounting cstrike.. OK
Mounting dod.. No permission
Mounting ep2.. Disabled
Mounting tf.. OK
Mounting episodic.. Disabled
Mounting hl2mp.. OK
Mounting portal.. Disabled
Mounting lostcoast.. Disabled
Mounting hl1.. No permission
Mounting hl1mp.. No permission
Mounting zeno_clash.. No permission
Mounting left4dead2.. No permission
Mounting left4dead.. No permission
Mounting diprip.. Disabled
Mounting zps.. Disabled
Mounting pvkii.. Disabled
Mounting dystopia.. Disabled
Mounting ageofchivalry.. Disabled
Garry's Mod server.dll Build #129 [Oct 17 2011 11:30:17]
maxplayers set to 128
Unknown command "sv_allow_wait_command"
Steam config directory: e:\program files\steam\steamapps\darkshadow120\garrysmod\platform\config
CClientSteamContext logged on = 1
Both ConVars must be marked FCVAR_REPLICATED for linkage to work (v_ipitch_level)
Both ConVars must be marked FCVAR_REPLICATED for linkage to work (v_iroll_level)
Both ConVars must be marked FCVAR_REPLICATED for linkage to work (v_iyaw_level)
Both ConVars must be marked FCVAR_REPLICATED for linkage to work (v_ipitch_cycle)
Both ConVars must be marked FCVAR_REPLICATED for linkage to work (v_iroll_cycle)
Both ConVars must be marked FCVAR_REPLICATED for linkage to work (v_iyaw_cycle)
Both ConVars must be marked FCVAR_REPLICATED for linkage to work (cl_bobup)
Both ConVars must be marked FCVAR_REPLICATED for linkage to work (cl_bob)
Both ConVars must be marked FCVAR_REPLICATED for linkage to work (cl_bobcycle)
Hud element 'CHudVote' doesn't have an entry 'CHudVote' in scripts/HudLayout.res
Garry's Mod client.dll Build #129 [Oct 17 2011 11:30:17]
maxplayers set to 1
Unknown command "cl_thirdperson"
Unknown command "hud_showemptyweaponslots"
Unknown command "sv_backspeed"
Not playing a local game.
GetAllManifestFiles:  Unable to load maplist.txt
Got toybox authentication
maxplayers set to 1


What is that mean, and how can I enable that? Thank you for your help in advance.

You need to enable it. From the main menu, go to Extensions > Game Content > make sure HL2:EP2 is checked. You’ll then need to restart your Garry’s Mod.