Error: "Access is denied"



** Executing...
** Command: "e:\program files\steam\steamapps\(snip)\sourcesdk\bin\orangebox\bin\vbsp.exe"
** Parameters: -game "g:\program files\steam\steamapps\(snip)	eam fortress 2	f" "G:\Program Files\Steam\steamapps\(snip)\sourcesdk_content	f\mapsrc\ch_giygasSPARTATEST"

* Could not execute the command:
   "e:\program files\steam\steamapps\(snip)\sourcesdk\bin\orangebox\bin\vbsp.exe" -game "g:\program files\steam\steamapps\(snip)	eam fortress 2	f" "G:\Program Files\Steam\steamapps\(snip)\sourcesdk_content	f\mapsrc\ch_giygasSPARTATEST"
* Windows gave the error message:
   "Access is denied."

** Executing...
** Command: "e:\program files\steam\steamapps\(snip)\sourcesdk\bin\orangebox\bin\vvis.exe"
** Parameters: -game "g:\program files\steam\steamapps\(snip)	eam fortress 2	f" "G:\Program Files\Steam\steamapps\(snip)\sourcesdk_content	f\mapsrc\ch_giygasSPARTATEST"

* Could not execute the command:
   "e:\program files\steam\steamapps\(snip)\sourcesdk\bin\orangebox\bin\vvis.exe" -game "g:\program files\steam\steamapps\(snip)	eam fortress 2	f" "G:\Program Files\Steam\steamapps\(snip)\sourcesdk_content	f\mapsrc\ch_giygasSPARTATEST"
* Windows gave the error message:
   "Access is denied."

** Executing...
** Command: "e:\program files\steam\steamapps\(snip)\sourcesdk\bin\orangebox\bin\vrad.exe"
** Parameters:  -game "g:\program files\steam\steamapps\(snip)	eam fortress 2	f" "G:\Program Files\Steam\steamapps\(snip)\sourcesdk_content	f\mapsrc\ch_giygasSPARTATEST"

* Could not execute the command:
   "e:\program files\steam\steamapps\(snip)\sourcesdk\bin\orangebox\bin\vrad.exe"  -game "g:\program files\steam\steamapps\(snip)	eam fortress 2	f" "G:\Program Files\Steam\steamapps\(snip)\sourcesdk_content	f\mapsrc\ch_giygasSPARTATEST"
* Windows gave the error message:
   "Access is denied."

I get this every single time I have attempted to compile this map I am making in TF2 for gmod, this is the first time I have mapped in the orange box engine in months, but I made sure the .fgd was fine, and everything looks good ingame.

Why must windows hate me so much? and what should I do?

You’re making a map in TF2 for Gmod? Why not just use the Episode 2 configuration for Gmod mapping? I have never heard of anyone using TF2 for such things.

Ontopic: Perhaps you could try checking if your game folders aren’t set as read only.

If you’re running Vista it could even be one of those “you have to run this program as admin or it will fuck you over” things again.

Which drive is everything installed to?

I’m having the exact same problem on XP.

so vista might not be the problem.

Are you using a custom hammer setup, or a default one?

Try to get to the folder you’re saving the maps to.

I had a similar problem with Sims 3 (for my sister - fucking hate that game) where the EA games folder had been blocked for some stupid reason.

Just going into it and allowing the user access fixed it.

Is it the first time you compile the map? If not, make sure the bsp isn’t read-only.

um, if you have parental controls thats why. if not, i dont know how to help.

Do you have experience with parental controls? (Had my self a little laugh at those home-school freaks.)

Anyway, I have always seen drive “E” as a Cd/DVD drive. But that’s not the issue here. My only thoughts would be to use a different configuration.

It’s most likely because you’re not on an admin account with some fucked up restrictions set.

you are running the compile tools from the E:/ drive but point to the G:/ drive for your map and game configuration. One of them is correct, figure out which one it is, then change the other so all the commands point to the same drive.



** Executing...
** Command: "c:\program files\steam\steamapps
erdrage94\sourcesdk\bin\vbsp.exe"
** Parameters: -game "c:\program files\steam\steamapps
erdrage94\garrysmod\garrysmod" "C:\Documents and Settings\Alex\My Documents\NCB20"

* Could not execute the command:
   "c:\program files\steam\steamapps
erdrage94\sourcesdk\bin\vbsp.exe" -game "c:\program files\steam\steamapps
erdrage94\garrysmod\garrysmod" "C:\Documents and Settings\Alex\My Documents\NCB20"
* Windows gave the error message:
   "Access is denied."

** Executing...
** Command: "c:\program files\steam\steamapps
erdrage94\sourcesdk\bin\vrad.exe"
** Parameters:  -game "c:\program files\steam\steamapps
erdrage94\garrysmod\garrysmod" "C:\Documents and Settings\Alex\My Documents\NCB20"

* Could not execute the command:
   "c:\program files\steam\steamapps
erdrage94\sourcesdk\bin\vrad.exe"  -game "c:\program files\steam\steamapps
erdrage94\garrysmod\garrysmod" "C:\Documents and Settings\Alex\My Documents\NCB20"
* Windows gave the error message:
   "Access is denied."

** Executing...
** Command: Copy File
** Parameters: "C:\Documents and Settings\Alex\My Documents\NCB20.bsp" "c:\program files\steam\steamapps
erdrage94\garrysmod\garrysmod\maps\NCB20.bsp"

The command failed. Windows reported the error:
  "The system cannot find the file specified."


I am sorry to bump this, but i have tried everything and cannot get it to compile, as it always states this error.

i am trying to get it to save into my Gmod maps folder, and i have tried compiling it into my documents.

i only have one account on my PC, and i’m running XP, ive tried without any firewall on but it still did not work,

any clear instructions on how i can test this map finally?

It’s better to bump an old thread than making a new one. Now we know a little more about your problem.

Can you actually access your GMod maps folder by going into program files>steam>steamapps>your steam name>garrysmod>garrysmod>maps?

yes, easily, ive tried keeping it open while compiling, no luck.

As people have said, what drive are you saving it to?

Also, if you’ve previously compiled the map, delete it then recompile and if that doesn’t work, copy everything into a new .vmf and name it something like gm_nerdragetest - so there’s nothing with the same name in your map folder.

I’m saving it all to my main C drive, i’ve copied everything into a fresh file, saved it, and tried compiling it, no luck.

Why doth windows punish me so?

Because windows is gay.

Could you try doing it on a different session on your PC, or even try it on the guest profile (that only takes 5 seconds to set up).



** Executing...
** Command: "c:\program files\steam\steamapps
erdrage94\sourcesdk\bin\vbsp.exe"
** Parameters: -game "c:\program files\steam\steamapps
erdrage94\garrysmod\garrysmod" "C:\Documents and Settings\Alex\My Documents\NCB20"

* Could not execute the command:
   "c:\program files\steam\steamapps
erdrage94\sourcesdk\bin\vbsp.exe" -game "c:\program files\steam\steamapps
erdrage94\garrysmod\garrysmod" "C:\Documents and Settings\Alex\My Documents\NCB20"
* Windows gave the error message:
   "Access is denied."

** Executing...
** Command: "**c:\program files\steam\steamapps
erdrage94\sourcesdk\bin\vrad.exe**"
** Parameters:  -game "c:\program files\steam\steamapps
erdrage94\garrysmod\garrysmod" "C:\Documents and Settings\Alex\My Documents\NCB20"

* Could not execute the command:
   **"c:\program files\steam\steamapps
erdrage94\sourcesdk\bin\vrad.exe"**  -game "c:\program files\steam\steamapps
erdrage94\garrysmod\garrysmod" "C:\Documents and Settings\Alex\My Documents\NCB20"
* Windows gave the error message:
   "Access is denied."

** Executing...
** Command: Copy File
** Parameters: "C:\Documents and Settings\Alex\My Documents\NCB20.bsp" "c:\program files\steam\steamapps
erdrage94\garrysmod\garrysmod\maps\NCB20.bsp"

The command failed. Windows reported the error:
  "The system cannot find the file specified."


i don’t know if it helps, but i checked and both the files highlighted do not exist in the bin folder, are they part of another file or did windows delete them?

i’m not sure, but i’m a big newb at mapping, ive recently put in home-made textures and overlays, ones i used VTFedit and made the VMF files myself, could this be to blame? as sometimes in 3d textured view in hammer, you can see the brushes behind the brushes with the custom textures.

note: the map worked fine before application of said textures, i’d hate to lose all the work i did before i applied these textures.

[editline]10:56PM[/editline]

tried compiling old versions of the map without custom textures, failed again!

Your configuration is set up wrong, the compile tools do not exist in those folders. They’re under sourcesdk\bin\ob\bin now. You can change this under the options menu and then the build programs tab.

Problem solved! thanks a lot, you are a real lifesaver!