Error compling

Here’s my .qc file:


$modelname    "mymodel\lolblock.mdl"
$body lolblock    "lolblock_ref.smd"
$staticprop
$surfaceprop    combine_metal
$cdmaterials    "models\mymodels"

$sequence idle    "lolblock_idle.smd"

$collisionmodel "lolblock_physbox.smd"

$keyvalues
{
    prop_data
    {
            base                    Metal.Small
            dmg.bullets                200
            explosive_damage        25
            explosive_radius        50
    }
}

All the directories are CORRECT. Everything is right. Now the problem; here’s the studiomdl.cmd when I try to put the .qc on it.


D:\steam\steamapps\6873golf\half-life 2\hl2\models\mymodels>"d:\steam\steamapps\
6873golf\sourcesdk/bin/orangebox/bin/studiomdl" -nop4 "D:\steam\steamapps\6873go
lf\half-life 2\hl2\models\mymodels\lolblock.qc"
qdir:    "d:\steam\steamapps\6873golf\half-life 2\hl2\models\mymodels\"
gamedir: "D:\steam\steamapps\6873golf\half-life 2\hl2\"
g_path:  "D:\steam\steamapps\6873golf\half-life 2\hl2\models\mymodels\lolblock.q
c"
Building binary model files...
Working on "lolblock.qc"
SMD MODEL lolblock_ref.smd
ERROR: d:\steam\steamapps\6873golf\half-life 2\hl2\models\mymodels\lolblock.qc(2
): - missing all bones in file 'lolblock_ref.smd'
ERROR: Aborted Processing on 'mymodel\lolblock.mdl'
WARNING: Leaking 1 elements

D:\steam\steamapps\6873golf\half-life 2\hl2\models\mymodels>pause
Press any key to continue . . .


What does that error mean? I tried exporting as an .smd again from XSI but not checking “remove all unused bones” and “remove top-level bone”, but that didn’t work.

[editline]25th June 2011[/editline]

bump, I really need help

I had that error recently because one of the “{” was out of place. I am still very much a novice with this stuff though, you could be having a completely different problem.

Me too, I’ll see if that’s the problem :slight_smile:

[editline]25th June 2011[/editline]

Nope. Still happening

[editline]25th June 2011[/editline]

Can someone help me?

[editline]25th June 2011[/editline]

In fact, there was no { out of place

Did you see this? It’s talking about your error.

http://www.polycount.com/forum/showthread.php?t=74482

His model has bones. Mine is just a physics prop (a box).

Even props need bones: