Error Every Time

I run Rust Then it ask to install EasyAntiCheat. I install it and this error comes up every time.

Please try and run the installer directly. You can find it in the rust installation folder, under EasyAntiCheat.
Does that work?

i’ve tried that as well also with admin privileges i also tryed doing the cmd that you suggested on a differnt post but for some reason it does not tell me that it was successful or Failed.
i got windows 7 64bit

Never mind i have found the problem out

I got the same problem, what was the solution?

I’ve got the same problem. What was your solution ? I also got 5 friends with the same issue. What’s going on EAC guys ? :frowning:

Myeah, fuck this buggy ass game and fuck this buggy ass anticheat

Same Problem too. I have reinstalled Rust, reinstalled AntiCheat, dont worked :frowning:

So does anyone know a fix

Hi,

Sorry about the issue, we will try to reproduce it and see why it can happen in the first place. Someone in this thread reported how he fixed it, could you see http://forum.facepunch.com/showthread.php?t=1434361 if it would help for you as well?

i can install it that way, go back to steam to launch game and it wants me to reinstall it again. run the game outside of steam and get booted from server 20 seconds later

[editline]31st October 2014[/editline]

this did not work either

@ Kubble : A wild update showed up few minutes ago and after updating my game works fine now. 3 of my friends already had this update and had their game fixed too. 2 of us missing ;p. I guess it was a version miss match thing.

Maybe you guys at EAC or the rust team could add a bit more info on those errors would help a LOT.

EDITED : the last two guys from our group got their update notification now… will see if it will fix for them too.

EDITED2 : HUZZA !!! It worked. I guess it was really a version missmatch.

i havent seen an update yet

Same

A friend of me has same problems with that.
I have not but i had only update my older version of rust and re needed to download the game complete new.

Reposting from the general board:

Here’s what I’ve noticed. If I run the EAC installer (as administrator), I can install/uninstall it no problem. It works fine, and I see the service in Services.msi and the registry entries. I can launch this Setup on its own and it sees what EAC versions are installed.

HOWEVER, when EAC’s installer is run by the Rust launcher itself, it has no idea that I’ve already installed it. It doesn’t see that it’s already installed. The “Uninstall” radio button is disabled.

Some sort of access issue.

I also noticed that the registry path is looking for EasyAntiCheat.exe in the System32 folder. There’s no file by that name in the folder.

I deleted/redownloaded the game from Steam. No change.

Getting this issue. Just bought the game today, haven’t been able to play other than legacy. Tried everything the best I got was connecting to a few servers for minutes before being disconnected. I see no new updates as there shouldn’t be since i just had it installed hours ago. Getting fairly irritating.

Hello,

Just been messing around with some registry files that I have copied from a friends working version of rust. After manually installing EAC from it’s setup file and applying the working registry to my computer, the game has started to work.

I will post an update in 10 minutes to verify my findings, I can also provide the working registry file for those who want to try it.

Cheers,

GoodGuyGrant.

UPDATE: Ok, it seems that my problems are now corrected. For those wanting to try the registry fix here is the link. Simply download and double click the file; It will apply a missing “ServiceVersion” registry entry.

I hope this can help some people out,

Cheers,

GoodGuyGrant.

Please go here and see if this will work for you http://forum.facepunch.com/showthread.php?t=1434361

[editline]1st November 2014[/editline]

Please go here and see if this will work for you http://forum.facepunch.com/showthread.php?t=1434361

[editline]1st November 2014[/editline]

Please go here and see if this will work for you http://forum.facepunch.com/showthread.php?t=1434361

Thanks man, that worked like a charm. Been looking for a solution for hours.

You should make a fix thread on it, to help those who don’t check here