Error Flir ???

Hi I have a new error on my server, I do not know where it comes from…

[ERROR] lua/autorun/client/flir.lua:9: attempt to call method ‘GetScriptedVehicle’ (a nil value)

  1. fn - lua/autorun/client/flir.lua:9
  2. unknown - addons/ulib/lua/ulib/shared/hook.lua:110

in lua/autoru/client I dont have “flir.lua”

Then it’s from an addon. Disable them until you find the specific addon.

It’s neurotanks
I deleted the addons

Thx.

I have this very same addon as well, it seems to have broken, (multiple lua files). The thing is, it isnt the addon from what I can tell, but rather something in gmod (was there a tiny change???) because I had the same files for weeks and they worked fine up until this morning(meaning I had the decompiled mod for weeks, so it isnt an addon update).

There hasn’t been a GMod update in months, and GetScriptedVehicle was removed in GM13: https://maurits.tv/data/garrysmod/wiki/wiki.garrysmod.com/index5914.html

so why has it worked up until now?

Either it wasn’t loading properly before or your code changed.

This will answer all your problems.
Hoffa has broken NeuroTec in his attempts to remove his back door ad player.

http://forum.facepunch.com/showthread.php?t=1535407

But it isnt just nuerotec, its all of GetScritedVehicle