Error for SWEP (TTT)

Most people on my server see a shuriken SWEP as an error. I tried adding a workshop collection to combat the issue, but it didn’t work.
I have it on the FastDL, and some people seem to be able to see it including myself, but a lot of people just see errors.

Any way to fix it?

Have you tried subscribing to the addon yourself to see if that fixes the error? Do you mind posting the code that you used to have people download the workshop collection?

It’s in the commandline.

Is it resource.AddFiled?

I’m not sure what that means. Could you elaborate?

Sorry, I’ve never actually come across that in the 2 years of owning a server.

That only downloads it to the server. You need to use resource.AddWorkshop

[editline]28th September 2015[/editline]

Or if its not by workshop, just

Where do I find/add this?

Example: Map https://steamcommunity.com/sharedfiles/filedetails/?id=419785989

At the end the thing from ?id wich would be 419785989.
That with all the workshop addons from your collection, in a autorun in the server

Okay, Autorun, got it.

[editline]28th September 2015[/editline]

How would I add the model to addfile?

I’m just adding these to a file in Autorun.

Autorun/server, not autorun

[editline]28th September 2015[/editline]

You need to specify where the file is located, EG: models/player/thidoneplayermodel.mdl

[editline]28th September 2015[/editline]

Also you need either fastdl or sv_allowdownload set to 1