ERROR: GAMEMODE:'HUDPaint' can any one help

me fix this please

ERROR: GAMEMODE:‘HUDPaint’ Failed: lua_temp\cider\gamemode\cl_init.lua:415: bad argument #1 to ‘GetTextSize’ (string expected, got nil)

also i need someone who is good at lua coding…please…anyone?

well can any one help please…Bump

Maye you should provided a little more information like:
The gamemode your using.

i am using cider gamemode on my server…

Show the code.

Connecting to 213.229.97.243:27018…
Connected to 213.229.97.243:27018

cider
Map: Gm_Construct
Players: 1 / 18
Build: 3943
Server Number: 1

No pure server whitelist. sv_pure = 0
Your .dll [bin\client.dll] differs from the server’s.
Unable to load voice codec ‘voice_speex’. Voice disabled.
Not deleting directory cache/dua/ (directory is locked)
Decompressing data pack into virtual file system…
Data pack loaded: 460 files. (2.982s)
Lua initialized (Lua 5.1)
Registering gamemode ‘Sandbox’ derived from ‘base’
Registering gamemode ‘cider’ derived from ‘Sandbox’
ERROR: Trying to derive entity gmod_xqm_wire_hydraulic from non existant entity base_wire_entity!
Sending 312 ‘User Info’ ConVars to server (cl_spewuserinfoconvars to see)
Redownloading all lightmaps

thats what i get in the console and on my screen its black with red wiriting saying…press jump if you are stuck on this loading screen

Try updating server with the hlds tool you used to download the server.

Connecting to 213.229.97.243:27018…
Connected to 213.229.97.243:27018

cider
Map: Gm_Construct
Players: 1 / 18
Build: 3943
Server Number: 1

No pure server whitelist. sv_pure = 0
Error reading material data “materials/experim3nt/gradient.vtf”
Error reading material data “materials/experim3nt/gradient.vtf”
Error reading material data “materials/experim3nt/gradient.vtf”
Error reading material data “materials/experim3nt/gradient.vtf”
Error reading material data “materials/experim3nt/gradient.vtf”
Unable to load voice codec ‘voice_speex’. Voice disabled.
Not deleting directory cache/dua/ (directory is locked)
Decompressing data pack into virtual file system…
Data pack loaded: 462 files. (0.596s)
Lua initialized (Lua 5.1)
Registering gamemode ‘Sandbox’ derived from ‘base’
Registering gamemode ‘cider’ derived from ‘Sandbox’
ERROR: Trying to derive entity gmod_xqm_wire_hydraulic from non existant entity base_wire_entity!
Sending 312 ‘User Info’ ConVars to server (cl_spewuserinfoconvars to see)
Redownloading all lightmaps

thats what i get after doing the update…any sugestions?

can any one help? …bump

Are you using fast download? if so update it/disable it to test, if that still doesn’t work contact the creator of the gamemode.

What addons you have? Did you update them?