Error I'm getting in GMod

What does this error mean?


MountFilesystem( 241 ) failed: SteamMountFilesystem(1648,241,0xab6fd58=,0xab6fc48) failed with error 5: No Steam Content Servers are available.

I get it when I try to launch GMod.

try deleting clientregistry.blob in your main steam folder or restarting steam

Oh! I forgot to mention that this is Garry’s Mod 9.0.4 I’m installing. (Yes, I have GMod from STEAM) I wanted to try out GMod 9.0.4 but I get this error whenever I try to launch it.

No one plays Gmod9 for a reason.

This.

I just wanted to mess around in GMod 9. My friends say there are plenty of servers.

Do you have Half-Life 2, Half-Life 2: Deathmatch, and Counter Strike: Source?
GMod 9.0.4 requires that you have all of these installed, and


launched at least once since install to work.

If you answered no to CS:S, then you can install GMod 9.0.3, and then delete any file that looks like it is associated in any way with CS:S (It worked with me when I tried GMod before I got it).

Furthermore, when I had GMod 9, I had an excruciatingly difficult time trying to join a server. I don’t know why I couldn’t, and the only server I was able to join sucked. If you ask me, GMod 9 isn’t worth the trouble if you have already bought it on Steam.

So 9.0.4 needs CS:S to launch? And 9.0.3 doesn’t?

Both versions “need” CS:S to work, but it is possible to do a patchy fix to 9.0.3 by manually going through its folder and deleting every CS:S associated file, thereby allowing it to work on a Steam account that does not have CS:S registered/installed on it.

As far as I know, this is not possible on 9.0.4.

Also, by using 9.0.3, I don’t think I need to say this, but you won’t be able to go on any servers.
I wouldn’t go on any servers if I were you anyways, since pre-GMod 10 lua downloads from servers can be malicious files.

Ok, thanks.