Error loading model. the model has no vertices.

What am I doing wrong? Recently I just tried to compile Mina mongoose only to have the HL Model Viewer reject her.


GUIStudioMDL 2.2/Source - © 2007 Neil 'Jed' Jedrzejewski - http://www.wunderboy.org/

Loaded QC file - "F:\E documents\Mina.qc"

Created command line: "G:\Program files\Steam\SteamApps\suroguner\sourcesdk\bin\ep1\bin\studiomdl.exe" -game "g:\program files\steam\steamapps\SourceMods\s2006worldcraftrepair" -notxbox "F:\E documents\Mina.qc"

qdir:    "f:\e documents\"
gamedir: "g:\program files\steam\steamapps\SourceMods\s2006worldcraftrepair\"
g_path:  "Mina"
Working on "Mina.qc"
SMD MODEL C:\Documents and Settings\windowsxp\My Documents\3dsmax\export\Ragdoll/ragdoll.smd
SMD MODEL C:\Documents and Settings\windowsxp\My Documents\3dsmax\export\Ragdoll/phymodel.smd
Processing jointed collision model
Collision model completed.
---------------------
writing g:\program files\steam\steamapps\SourceMods\s2006worldcraftrepair\models/Mina.mdl:
bones          420 bytes (0)
animations     104 bytes (1 anims) (101 frames) [0:03]
sequences      216 bytes (1 seq) 
ik/pose          0 bytes
textures        72 bytes
keyvalues        0 bytes
collision        0 bytes
total          892

Completed "Mina.qc"
Created command line: "G:\Program files\Steam\SteamApps\suroguner\sourcesdk\bin\orangebox\bin\studiomdl.exe" -game "g:\program files\steam\steamapps\suroguner	eam fortress 2	f" -nop4 -nox360 "F:\E documents\Mina.qc"

qdir:    "f:\e documents\"
gamedir: "g:\program files\steam\steamapps\suroguner	eam fortress 2	f\"
g_path:  "F:\E documents\Mina.qc"
Building binary model files...
Working on "Mina.qc"
SMD MODEL C:\Documents and Settings\windowsxp\My Documents\3dsmax\export\Ragdoll/ragdoll.smd
SMD MODEL C:\Documents and Settings\windowsxp\My Documents\3dsmax\export\Ragdoll/phymodel.smd
Processing jointed collision model
Bone01                   (260 verts, 1 convex elements) volume: 181.69
Bone02                   (403 verts, 1 convex elements) volume: 770.86
Bone09                   ( 69 verts, 1 convex elements) volume: 554.47
Bone10                   (154 verts, 1 convex elements) volume: 2167.81
Bone07                   ( 36 verts, 1 convex elements) volume: 35.82
Bone06                   (246 verts, 1 convex elements) volume: 94.57
Bone08                   (123 verts, 1 convex elements) volume: 69.45
Bone03                   ( 36 verts, 1 convex elements) volume: 35.82
Bone04                   (246 verts, 1 convex elements) volume: 94.57
Bone05                   (123 verts, 1 convex elements) volume: 69.45
Bone11                   ( 81 verts, 1 convex elements) volume: 7.26
Bone12                   ( 87 verts, 1 convex elements) volume: 22.85
ValveBiped.Bip01_L_Hand  (321 verts, 1 convex elements) volume: 10.71
Bone13                   ( 81 verts, 1 convex elements) volume: 6.70
Bone14                   ( 87 verts, 1 convex elements) volume: 23.63
ValveBiped.Bip01_R_Hand  (321 verts, 1 convex elements) volume: 11.00
Collision model completed.
---------------------
writing g:\program files\steam\steamapps\suroguner	eam fortress 2	f\models/Mina.mdl:
bones          676 bytes (0)
animations     112 bytes (1 anims) (101 frames) [0:03]
sequences      216 bytes (1 seq) 
ik/pose          0 bytes
textures        72 bytes
keyvalues        0 bytes
bone transforms        0 bytes
Collision model volume 4156.66 in^3
collision        0 bytes
total         1156

Completed "Mina.qc"


The parts that concern me right now are the bits with 0 bytes.

Project files can be found here: http://www.mediafire.com/?wi961uosadugd20

Would modifying the original model so that it’s slightly different do this?

add $model “studio” “reference.smd” to your QC - you did not include the main SMD, it only compiled the phymodel and the animation… the outcome is logically a bit… dull? :wink:

I can’t believe this, my problem was caused by deleting to much from another qc.

Thank you. It worked.