error on darkrp server

Whenever I start my server I get no errors on console but after some time, when someone joins he get these errors;


[ERROR] A runtime error has occurred in "gamemodes/darkrp/gamemode/modules/base/sv_gamemode_functions.lua" on line 687.
The best help I can give you is this:

DarkRP was unable to introduce player "Youssa" to the game. Expect further errors and shit generally being fucked!

Hints:
	- This error most likely does not stand on its own, and previous serverside errors have a very good chance of telling you the cause.
	- Note that errors from another addon could cause this. Specifically when they're thrown during 'PlayerInitialSpawn'.
	- This error can also be caused by some other addon returning a value in 'PlayerInitialSpawn', though that is less likely.
	- Errors in your DarkRP configuration (jobs, shipments, etc.) could also cause this. Earlier errors should tell you when this is the case.

The responsibility for the error above lies with (the authors of) one (or more) of these files:

------- End of Simplerr error -------

[ERROR] A runtime error has occurred in "[C]" on line -1.
The best help I can give you is this:

DarkRP was unable to introduce player "Youssa" to the game. Expect further errors and shit generally being fucked!

Hints:
	- This error most likely does not stand on its own, and previous serverside errors have a very good chance of telling you the cause.
	- Note that errors from another addon could cause this. Specifically when they're thrown during 'PlayerInitialSpawn'.
	- This error can also be caused by some other addon returning a value in 'PlayerInitialSpawn', though that is less likely.
	- Errors in your DarkRP configuration (jobs, shipments, etc.) could also cause this. Earlier errors should tell you when this is the case.

The responsibility for the error above lies with (the authors of) one (or more) of these files:
	1. function 'Spawn'
	2. gamemodes/base/gamemode/player.lua on line 115
------- End of Simplerr error -------
.....
(SAME ERROR FOR ALL OTHER PLAYERS TOO)

I dont know what to do with this errors. Do you guys have any suggestion?

That means either a PlayerInitialSpawn hook from an addon is returning inside the hook, blocking the gamemode function from being ran, or there’s an earlier error with one of these functions: https://github.com/FPtje/DarkRP/blob/master/gamemode/modules/base/sv_gamemode_functions.lua#L584-L587

I should see the error if there is right? I don’t see any, so should I check every playerinitialspawn hook and the function?

Yeah, make sure none return a value in the hook.

Thank you.