Error on Startup... Gah...

Whenever I start up GMod 10, it stops before it gets to the main title menu, and gives me this error exactly:

Garry’s Mod: hl2.exe - Application Error

The instruction at “0x380dc0d0” referenced memory at “0x00000010”. The memory could not be “read”.

Click on OK to terminate the program

OK

Confusion, and a question:
Whattodo!?

i’ll repeat the fix a bit more decently.

Go to your C:\Program Files\steam\steamapps\Username\garrysmod\garrysmod \cfg
There you will find a file called Content.txt , open that file with notepad/wordpad.
and remove all the text inside it, and replace it with this.

“Content”
{
“240”
{
“mount”“1”
}
“420”
{
“mount”“1”
}
“380”
{
“mount”“1”
}
“300”
{
“mount”“1”
}
“340”
{
“mount”“1”
}
“360”
{
“mount”“1”
}
“400”
{
“mount”“1”
}
}

Then save your file, close it, and simply start up your garry mod.
End of story for today, when valve releases a fix for it, simply go to your garry mod.
in the menu you get at the beginning , when you first start up your garry mod.
you will find something called: Gmod settings.
and there you can enable all your games back on.
for now, if you enable Team fortress 2 also, your garry mod will no longer work

Sop making threads about it >.<

Same problem here.

Follow my fix and problem is solved …

Read the fix!

[editline]02:40AM[/editline]

Please, do a thread about it, people are too retarded to read.

I don’t have a cfg folder. :frown:

Create the map CFG yourself and also create the file content.txt yourself and then add the data i supplied you.

That kinda explains you crashing…

Ah ha. I figured out the problem with help from killabeat (though it was indirect).

If you have TF2 content mounted, you will crash.

Solution: Remove this block:


"440"
{
"mount""1"
}

If everything is in one line, edit with gVim.

(If you say “BUT NOTEPAD++ IS BETTER WAAA”, Notepad++ doesn’t support Unix file format last I checked, which is what content.txt is normally in. gVim DOES support it)

yes it does.

OK then, if you have Notepad++, go ahead and use it. I still prefer gVim.

Uh, thanks guys for the help, and I’ll keep that in mind… But I got another suggestion from a friend right after posting… he suggested clearing out the addons folder, and the other folders a bit, and well it worked… I’m still stumped about what it meant, but it’s a non-issue. If it happens again I’ll try your suggestions…
Sorry for wasting your time like this.