(Error)Protobuf error in rust which disconnects the player. any body else ?

was wondering if anyone was getting same error and if they had managed to find a fix or temp fix

Thanks

at ProtoBuf.PersistantPlayer.DeserializeLengthDelimited (System.IO.Stream stream, ProtoBuf.PersistantPlayer instance) [0x00000] in <filename unknown>:0
at ProtoBuf.PersistantPlayer.DeserializeLengthDelimited (System.IO.Stream stream) [0x00000] in <filename unknown>:0
at ProtoBuf.BasePlayer.DeserializeLengthDelimited (System.IO.Stream stream, ProtoBuf.BasePlayer instance) [0x00000] in <filename unknown>:0
at ProtoBuf.BasePlayer.DeserializeLengthDelimited (System.IO.Stream stream) [0x00000] in <filename unknown>:0
at ProtoBuf.Entity.Deserialize (System.IO.Stream stream, ProtoBuf.Entity instance) [0x00000] in <filename unknown>:0
at ProtoBuf.Entity.Deserialize (System.Byte buffer) [0x00000] in <filename unknown>:0
at Client.OnEntities (Network.Message packet) [0x00000] in <filename unknown>:0
at Client.OnNetworkMessage (Network.Message packet) [0x00000] in <filename unknown>:0
at Network.Implementation.Raknet.Client.HandleMessage () [0x00000] in <filename unknown>:0

looks like this?
http://cloud-2.steamusercontent.com/ugc/38616669889305890/130FA2C80C3F1B20679351DADB1CE17EADAF061A/

oh yeah, another one of the crash issue i have.

same here… since friday i cant play… nice weekend :confused:

disconnecting: Invalid field id: 0, something went wrong in the stream
at ProtoBuf.BlueprintList.DeserializeLengthDelimited (System.IO.Stream stream, ProtoBuf.BlueprintList instance) [0x00000] in <filename unknown>:0
at ProtoBuf.BlueprintList.DeserializeLengthDelimited (System.IO.Stream stream) [0x00000] in <filename unknown>:0
at ProtoBuf.PersistantPlayer.DeserializeLengthDelimited (System.IO.Stream stream, ProtoBuf.PersistantPlayer instance) [0x00000] in <filename unknown>:0
at ProtoBuf.PersistantPlayer.DeserializeLengthDelimited (System.IO.Stream stream) [0x00000] in <filename unknown>:0
at ProtoBuf.BasePlayer.DeserializeLengthDelimited (System.IO.Stream stream, ProtoBuf.BasePlayer instance) [0x00000] in <filename unknown>:0
at ProtoBuf.BasePlayer.DeserializeLengthDelimited (System.IO.Stream stream) [0x00000] in <filename unknown>:0
at ProtoBuf.Entity.Deserialize (System.IO.Stream stream, ProtoBuf.Entity instance) [0x00000] in <filename unknown>:0
at ProtoBuf.Entity.Deserialize (System.Byte buffer) [0x00000] in <filename unknown>:0
at Client.OnEntities (Network.Message packet) [0x00000] in <filename unknown>:0
at Client.OnNetworkMessage (Network.Message packet) [0x00000] in <filename unknown>:0
at Network.Implementation.Raknet.Client.HandleMessage () [0x00000] in <filename unknown>:0

**
NEW ERROR: **

Got larger VarInt than 64 bit unsigned
at SilentOrbit.ProtocolBuffers.ProtocolParser.ReadUInt64 (System.IO.Stream stream) [0x00000] in <filename unknown>:0
at ProtoBuf.BlueprintList.DeserializeLengthDelimited (System.IO.Stream stream, ProtoBuf.BlueprintList instance) [0x00000] in <filename unknown>:0
at ProtoBuf.BlueprintList.DeserializeLengthDelimited (System.IO.Stream stream) [0x00000] in <filename unknown>:0
at ProtoBuf.PersistantPlayer.DeserializeLengthDelimited (System.IO.Stream stream, ProtoBuf.PersistantPlayer instance) [0x00000] in <filename unknown>:0
at ProtoBuf.PersistantPlayer.DeserializeLengthDelimited (System.IO.Stream stream) [0x00000] in <filename unknown>:0
at ProtoBuf.BasePlayer.DeserializeLengthDelimited (System.IO.Stream stream, ProtoBuf.BasePlayer instance) [0x00000] in <filename unknown>:0
at ProtoBuf.BasePlayer.DeserializeLengthDelimited (System.IO.Stream stream) [0x00000] in <filename unknown>:0
at ProtoBuf.Entity.Deserialize (System.IO.Stream stream, ProtoBuf.Entity instance) [0x00000] in <filename unknown>:0
at ProtoBuf.Entity.Deserialize (System.Byte buffer) [0x00000] in <filename unknown>:0
at Client.OnEntities (Network.Message packet) [0x00000] in <filename unknown>:0
at Client.OnNetworkMessage (Network.Message packet) [0x00000] in <filename unknown>:0
at Network.Implementation.Raknet.Client.HandleMessage () [0x00000] in <filename unknown>:0

i found updating my vid card drivers helped make it happen less frequently but still happens i get it alot when switching between weapons or tools

Yeah exactly the same :frowning:

Hey i fixed it, (my english is so bad so i will try to explain). It worked for me maybe it wasn’t for u…
So first u go in comptability of “rustclient” and click on “always run as administrator”.
Finaly u click on “execute this program in mode comptability for:” “windows Vista Service pack 1”.

Hope can help u ask me if u don’t understand or if it don’t work for u.