Error: System cannot find the file specified.

Ok, so i was making a map, and this exact error popped up, and the map stopped compiling.

Error: System cannot find the file specfied.
Would you like to continue?
<‘OK’ button>

so, i was pretty annoyed by this, and don’t remember it ever happening.
so i turn to you guys.

[lua]
** Executing…
** Command: “e:\program files\steam\steamapps\wardino389\sourcesdk\bin\ep1\bin\vbsp.exe”
** Parameters: -game “e:\program files\steam\steamapps\wardino389\half-life 2 deathmatch\hl2mp” “C:\Users\Wardino388\Desktop\gm_flattexture\gm_flattexture_TB1”

Valve Software - vbsp.exe (Dec 11 2006)
2 threads
materialPath: e:\program files\steam\steamapps\wardino389\half-life 2 deathmatch\hl2mp\materials
Loading C:\Users\Wardino388\Desktop\gm_flattexture\gm_flattexture_TB1.vmf
fixing up env_cubemap materials on brush sides…
ProcessBlock_Thread: 0…1…2…3…4…5…6…7…8…9…10 (0)
**** leaked ****
Entity func_brush (0.00 0.00 -16288.00) leaked!
Processing areas…done (0)
Building Faces…done (0)
FixTjuncs…
PruneNodes…
WriteBSP…
done (0)
Creating default cubemaps for env_cubemap using skybox materials:
skybox/sky_day01_01*.vmt
Run buildcubemaps in the engine to get the correct cube maps.

No such variable “$hdrbasetexture” for material “skybox/sky_day01_01rt”
Can’t load skybox file skybox/sky_day01_01 to build the default cubemap!
Finding displacement neighbors…
Finding lightmap sample positions…
Displacement Alpha : 0…1…2…3…4…5…6…7…8…9…10
Building Physics collision data…
done (0) (7199 bytes)
Placing detail props : 0…1…2…3…4…5…6…7Error! Too many detail props emitted on this map!

** Executing…
** Command: “e:\program files\steam\steamapps\wardino389\sourcesdk\bin\ep1\bin\vvis.exe”
** Parameters: -game “e:\program files\steam\steamapps\wardino389\half-life 2 deathmatch\hl2mp” -fast “C:\Users\Wardino388\Desktop\gm_flattexture\gm_flattexture_TB1”

Valve Software - vvis.exe (Nov 8 2007)
fastvis = true
2 threads
reading c:\users\wardino388\desktop\gm_flattexture\gm_flattexture_TB1.bsp
Error opening c:\users\wardino388\desktop\gm_flattexture\gm_flattexture_TB1.bsp

** Executing…
** Command: “e:\program files\steam\steamapps\wardino389\sourcesdk\bin\ep1\bin\vrad.exe”
** Parameters: -game “e:\program files\steam\steamapps\wardino389\half-life 2 deathmatch\hl2mp” -noextra “C:\Users\Wardino388\Desktop\gm_flattexture\gm_flattexture_TB1”

Valve Software - vrad.exe SSE (Nov 8 2007)
----- Radiosity Simulator ----
2 threads
[Reading texlights from ‘lights.rad’]
[45 texlights parsed from ‘lights.rad’]

Loading c:\users\wardino388\desktop\gm_flattexture\gm_flattexture_TB1.bsp
Error opening c:\users\wardino388\desktop\gm_flattexture\gm_flattexture_TB1.bsp

** Executing…
** Command: Copy File
** Parameters: “C:\Users\Wardino388\Desktop\gm_flattexture\gm_flattexture_TB1.bsp” “e:\program files\steam\steamapps\wardino389\half-life 2 deathmatch\hl2mp\maps\gm_flattexture_TB1.bsp”

The command failed. Windows reported the error:
“The system cannot find the file specified.”[/lua]

theres the compile log, or what i could copy out of it.

Go to map>loadpointfile and patch the hole, entities nor displacements patch them.

As for the can’t be found, it could be because of your drives, I don’t know exactly how to fix it.

ok, so i found the leaked entities, then it told me i had to many prop_details, so i realized i had 50 too many spawn points, and cut it down to 10.

now the damn compile log won’t show up.

now what do i do?

Restart hammer and compile again.

[editline]07:18PM[/editline]

And change the texture’s .vmt so it doesn’t have as many detail props.

detail props are in a texture?

i’m not even using a custom textures…

although i AM using a large field of detailed textures…

and i have changed the lightmap size on them.

The texture you are using for the displacement has detail props, open up the .vmt of the texture and change how spread out the detail props are. (They are the little grass sprites you see sticking out of the ground.)

Patch your leaks and remove some props

Removing proprs won’t help, Firegod is correct.

you’re using a blend texture that uses detail props in too many places, like blendgrassdirt01. Use the _noprop version to reduce the number of detail props in the map.

Last time I checked hl2:dm didn’t have _noprop default textures, although he could be using a custom one I guess.