Error unserializing VTF file... is the file empty?

I’m trying to fix a model that broke with the steampipe update. I believe it has something to do with file case modifications.

I’m getting an error saying:


*** Error unserializing VTF file... is the file empty?Error reading material data "materials/models/daftpunk/dafthelmet_animation.vtf"

The original file was DaftHelmet_animation.vtf. I tried changing the case so it matched it, but it’s still giving the same error. VTFEdit can open it fine, and I tried resaving it, but to no avail. Any ideas what might be going on?

Make the filesize smaller. I remember looking at this when a bug report came in, the filesize is 25 FUCKIN MEGABYTES.

Animated VTF at 1024x1024 when it’s almost all flat colors. Downscale that VTF to 256x256 or 128x128.

Yikes! that’s pretty bad… however, I have seen much worse.

Brace yourselves:

All combined textures comes in at a whopping 170MB

:suicide:

I resized the texture to 256x256 bringing it down to 2MB, but I’m still getting the same error. Any ideas?

Is the VTF version correct?

VTFEdit says it’s version 7.2.

Did you disable the “VTF thumbnail” thing?

I’m not sure how to.

Here’s what my current VTFs/VMFs for it are: https://dl.dropboxusercontent.com/u/2744683/daftpunk.rar