Error when compiling a model with GUIStudioMDL 2.2

“SteamStartup() failed: SteamStartup(0xf,0x0026FACC) failed with error 1: failed to take master pipe connection lock”

I have NO idea what this means, i’ve never seen it before, and only know has this program start to fuck up for me.

Sometimes when I get this error, it breaks source SDK, as in when I try to launch it, my avatar border goes green for a second, then goes back to blue.

Every “solution” I have found hasn’t worked. This involves restarting steam, restarting my PC, deleting my steam folder (save steamapps), deleting my sourcesdk folder, and redownloading GUIStudioMDL.

Oh and when I googled this, I only found a bunch of useless threads where some unlucky modder got the same error as me and 3 pages of posts basically saying “I got the same error too.”

verify integrity of sdk’s game cache

always fixes it for me

Didn’t work.

shit

that always works for me

I also get this error sometimes too:

SteamStartup() failed: SteamStartup(0xf,0x0016F4EC) failed with error 1: Failed create pipe: 6, Win32 Error 6 “The handle is invalid.”

Since this is a thread about GUIStudiomdl, I might as well ask a question too. I received the error “ERROR: ‘EXCEPTION_ACCESS_VIOLATION’ (assert: 1).” On the Valve dev website, it says that this comes from $shadowlod, but I hadn’t been using that command at all. Anyone know how to fix this?

restart steam

this should fix both of your issues

[editline]23rd April 2013[/editline]

and yes ft I know you’ve tried but try again son

Tried again like 5 times.

Got this first:

SteamStartup() failed: SteamStartup(0xf,0x0028F67C) failed with error 1: Failed create pipe: 6, Win32 Error 6 “The handle is invalid.”

And after the 2nd or 3rd try I got this:

SteamStartup() failed: SteamStartup(0xf,0x0028F6BC) failed with error 1: failed to take master pipe connection lock

that’s pretty weird, hmm

Perhaps you can try this, I know its not when you start a game but it could still apply.

Yeah, this happens to me every now and then, and restarting Steam usually works.

Sometimes you may have to do it more than once. I think I had to do it twice in a row once.

Didn’t work.

Have you tried compiling a different model, do all models do this?

They all do this.

i keep getting this error when compiling my p228 from CSS,



Created command line: "C:\Program Files\Steam\SteamApps\-------\sourcesdk\bin\orangebox\bin\studiomdl.exe" 

-game "c:\program files\steam\steamapps\--------\counter-strike source\cstrike" -nop4 -nox360 C:\Users\gamer\Desktop\BF3\CSS\extracted\P228\mdldecompiler.qc

MountAppFilesystem() failed:  SteamMountAppFilesystem(4294967295,4294967295,0x1733fa3c) failed with error 4: Bad launch configuration



Any Help?

I HAVE NO IDEA WHAT TO DO. its doing this with almost all my weapons…

CS:S was recently updated, dude. Compiling for that game is pretty much broken atm.

Anywho, getting back on topic. I’ve had this issue before a couple years ago. Unfortunately, I ended up having to completely re-install Steam just to make it work properly again. Since verifying the integrity of the Source SDK’s tool cache didn’t work, there’s a chance that you might need to do the same.

You mean like, deleting EVERYTHING in the steam folder? Even all the games?

Sadly, yes. Like I stated, I ended up having to do a complete re-install of Steam itself just to make it work properly again. It’s not exactly something I’d suggest unless it’s a last resort, but considering that you pretty much did everything that I had and ended up with the same results, that might have to be what you do.

If this doesn’t work I am going to scream.

DIDN’T WORK. WHO WOULD HAVE THOUGHT.

[editline]25th April 2013[/editline]

I’ve got one last idea.

Can someone send me their sourcesdk folder?