Error when starting up Hammer in Source:SDK

I am going to give as much information as I can. I just started mapping again, and after working on a map for about a day, I wanted to test it (in Garry’s Mod naturally) So I go to the options tab (I think) and set the map to compile the .bsp into my garrysmod/garrysmod/maps. I am using CounterStrike: Source (2009 engine) and these errors happen.

-The textures (I have three, one of which, was the developer texture) were black and pink [missing], yet I believe they were textures from CS:S.

  • After exiting Gmod, I try to start up Hammer again, and get this error.

“MountFilesystem(217) failed:
SteamMountFilesystem(4076,217,0xb11fd28=,0xb11fc18) failed with error 5:
No CS online with app 217 ver66”

I assume this has something to do with mounting the map compiling to a .bsp to my garrysmod and not changing ANYTYHING else except that single file path. This has never happened before, and I have saved, and worked on Hammer, and this map, for a while.

BTW I do Own Steam, SourceSDK, Counterstrike Source, and Garry’s Mod.

Try restarting steam.

Also, there are question megathreads, please post in them next time.

I have restarted Steam twice, and then restarted my computer. No positive results, same error.

[editline]09:57PM[/editline]

And sorry about making a thread, didn’t think to look for a question megathread.

Try deleting your steam\steamapps\sourcesdk folder.

Same issue, I deleted the folder, it started, copied the files, everything looked good. Then I push Hammer, and BAM same error.

[editline]10:57PM[/editline]

:::::::EXTRA I JUST LEARNED ABOUT NEWS:::::::

So CS:S isn’t even mounting correctly into G-Mod at all as well. When I attempt to spawn CS:S props, they don’t spawn. Guns give me v_model errors, and I do have the game mounted in extensions.