Error with adding images to fastdl

I made a derma with a picture on it and i need to add the images to fastdl. I converted it to vmt and vtf files for it, but it still doesn’t work. I probably converted into vmt and vtf wrong because i wasn’t sure about the settings. Can anybody help me if they know how.

You can add .jpg and .png files to the FastDL.

[editline]25th February 2015[/editline]

But does the problem lie with the actual files or the FastDL?

code_gs when i do that you cant see the images in the derma menu

Just having the file in the FastDL doesn’t make the clients download them. Make sure you resource.AddFile the images.

Setting up FastDL can be tricky. It’s possible to have FastDL download files into the completely wrong directory meaning they’ll download once, but they won’t work. It’s easy to have other issues happen too:

I’d recommend using png files… Also, put the content in your SERVER in gamemodes/gamemode_name/content/* and use this:

It’ll automatically call resource.AddSinglefile on all content. It’ll also let you use empty .gma files if you need to extract gma files to remove Lua ( such as backdoors or bad code but lets you keep using the models or whatever if you like the addon ) by putting them in gamemodes/gm_name/content/workshop/ name them whatever you want, but make sure the only DIGITS in the name are from the work shop id…

If you don’t want all workshop files to be added from gmod/addons/ comment out the line that does it.

Hopefully this helps.

Do you have a linux server? if so, make sure they are lowercase.