Errors driving me nuts

I have OCD, I cannot stand seeing these errors please help

The map is ttt_bank_b13 I get these errors when I join

These are Errors I get when starting up my server (server web console)

Error - no MetaName string type for userdata (AGH!)
area7 has Door model (models/props_c17/door01_left.mdl) with no door_options! Verify that SKIN is valid, and has a corresponding options block in the model QC file
area6 has Door model (models/props_c17/door01_left.mdl) with no door_options! Verify that SKIN is valid, and has a corresponding options block in the model QC file
Dynamic prop prop_dynamic: no sequence named:hackPowerBox
Nav File is wrong or something (1)
KeyValues Error: RecursiveLoadFromBuffer: got NULL key in file materials/jaanus/shuriken.vmt
VertexLitGeneric,
KeyValues Error: RecursiveLoadFromBuffer: got NULL key in file materials/jaanus/shuriken.vmt
VertexLitGeneric,
SOLID_VPHYSICS static prop with no vphysics model! (models/props_lab/corkboard002.mdl)
SOLID_VPHYSICS static prop with no vphysics model! (models/props_lab/corkboard001.mdl)

welcome to gmod

[editline]28th July 2016[/editline]

Doesn’t seem like too much, unless they repeat themselves.
and, I know the feeling, im slowly gutting myself whenever I take a peek at my server console.
I have the same ‘X has Door Model (some/door/model.mdl) with no door SO ON AND SO FOURTH’ error on rp_bangclaw, but it isnt too much.
TLDR: Nothing can really be done, because it really isnt a problem in the first place

Errors in packed textures. If you really want to fix these, you can get Pakrat and something and grab all the textures and fix them, but it’s not worth the effort.

Thanks guys

1 thing

KeyValues Error: RecursiveLoadFromBuffer: got NULL key in file materials/jaanus/shuriken.vmt
VertexLitGeneric,

Every client / server that has this addon always has this red error, anyone know of a fix?

Glad to know that my server is stable

[editline]28th July 2016[/editline]

Nav File is wrong or something (1)

non texture error I’m pretty sure

[editline]28th July 2016[/editline]

and this
Error - no MetaName string type for userdata (AGH!)

You could find that material and fix the error, however, it won’t override the client’s version. You’d have to recompile/hex the model to use a new material name. If you really want it fixed for your server and clients who join without it yet, post the VMT contents here (you can open it in notepad) and I can fix it.

[editline]28th July 2016[/editline]

Nav File is wrong or something (1)

Unfixable without making a nav file for your map (bots/default NPC pathing around a map). It’s not an issue.

Thanks for offering help, I guess that jaanus error does not really matter

I’m concerned about these 2 errors. They happen on startup

Error - no MetaName string type for userdata (AGH!)

Error - no MetaName string type for userdata (AGH!)

Some module or engine method isn’t using LUA->CheckType/casting the UserData before using it, iirc

Thank You, I’m guessing these errors do not hinder client/server performance.

Thank You for help

It can also happen in the Lua state if you use a userdata function without sending the data back. Ex. Vector().Whatever() vs Vector():Whatever(). Without any specific error, it’s hard to find.

[editline]28th July 2016[/editline]

Automerge

I don’t know lua lol. Do you mid if I pm you, you seem to have some deep knowledge in lua?

Sure