Errors while trying to download addons from Workshop

When my Garry’s Mod client tries to download some addons from Workshop that are requested by server via resource.AddWorkshop, there’s many “Addon download failed err2 (<addon name here>)” errors in console, and no one from server’s collection addons can’t download.

The collection is here: http://steamcommunity.com/sharedfiles/filedetails/?id=734175916
As I can see in Steam\SteamApps\workshop\content\4000, my Garry’s Mod client has downloaded only 819421137 (“Cultist Playermodel & Ragdoll”) and 825411360 (“Drugs Mod [RUS] [No backdoor]”) addons.

If I manually choose to download all addons from this collection, I can see


Download Finished
Error downloading file! [9]
END: DownloadAddons

for every “downloaded” addon in console, and at the end, as I mentioned above, I only have two addons downloaded, but this time I even have third addon - 457212613 (“STAR WARS Emperor Palpatine Playermodel”).

All of actions above I’ve tried on clean Garry’s Mod install.

Hope someone can help with this issue.

Try the dev branch. If it doesn’t help, you’re out of luck I guess. Error 9 is “file not found”. https://steamerrors.com/

Can also try making sure Steam is up to date.

[editline]28th January 2017[/editline]

Or just try waiting it out in case Steam has a bad day.

Just checked now, my Steam is up to date at the moment.

Tried to download the collection on “dev” branch - all is okay. Then tried “release” - all addons downloaded too. I think it was some sort of Steam Workshop API error or something like that.

Yeh I had this problem today too. Couldn’t download anything. Errors in every server I tried to join. Seems to have fixed itself though.