Ever since new update, srcds won't start

EDIT
Resolved.
apt-get install ia32-libs

If you need anymore info I will do my best to retrieve it.

EDIT
Sometimes, it skips saying all the errors after /tmp/dumps/crash_20110625183529_1.dmp

and says Segmentation fault

Update again with -verify_all.

[editline]26th June 2011[/editline]

If that fails.

Add “-debug” to the orangebox/srcds_run command line to generate a debug.log to help with solving this problem

I tried all of these:
./steam -command update -game tf -dir . -verify_all
./steam -command update -game garrysmod -dir . -verify_all
./steam -command update -game “Counter-Strike Source” -dir . -verify_all

Debug log:




----------------------------------------------
CRASH: Sat Jun 25 18:54:50 CDT 2011
Start Line: ./srcds_linux -console -debug -game garrysmod -condebug +maxplayers 32 +map rpw_downtown_v3b +fps_max 68 -tickrate 66 +sv_scriptenforcer 1 +sv_defaultgamemode darkrp -autoupdate -ip xxxxxxxxxxx -port 27015
End of Source crash report
----------------------------------------------


EDIT
After re-downloading all the bins



----------------------------------------------
CRASH: Sat Jun 25 19:16:41 CDT 2011
Start Line: ./srcds_linux -console -debug -game garrysmod -condebug +maxplayers 32 +map rpw_downtown_v3b +fps_max 68 -tickrate 66 +sv_scriptenforcer 1 +sv_defaultgamemode darkrp -autoupdate -ip xxxxxxxx -port 27015
[New Thread 16409]
[New Thread 16408]
[New Thread 16407]
Core was generated by `./srcds_linux -console -debug -game garrysmod -condebug +maxplayers 32 +map rpw'.
Program terminated with signal 11, Segmentation fault.
#0  0xef71a7e7 in ?? ()
#0  0xef71a7e7 in ?? ()
No symbol table info available.
eax            0x0	0
ecx            0x0	0
edx            0x2	2
ebx            0xef7eeacc	-276895028
esp            0xef718bce	0xef718bce
ebp            0xef718c08	0xef718c08
esi            0x0	0
edi            0x0	0
eip            0xef71a7e7	0xef71a7e7
eflags         0x10202	[ IF RF ]
cs             0x23	35
ss             0x2b	43
ds             0x2b	43
es             0x2b	43
fs             0x0	0
gs             0x63	99
From        To          Syms Read   Shared Object Library
0xf7751830  0xf7768a4f  Yes (*)     /lib/ld-linux.so.2
(*): Shared library is missing debugging information.
End of Source crash report
----------------------------------------------

i tired this and I still get the same error anyone else got any ideas?

Are you running on linux too?

I am running my Server on linux aswell. Updating the ia32-libs havent solved the problem. Valve please fix that, my Sourcegameserver wont run anymore.

Same problem here too. Also running a linux server.

Same problem here. Running x64 debian.

Delete all the files from all the /bin folders, should be three.

/bin
/orangebox/bin
/orangebox/garrysmod/bin

Then re-update with the -verify_all parameter.

Didn’t work for me.

Atleast I don’t have the first directory you’ve mentioned anyway. Neither on the linux server or on my local windows server.

The problem is that we’re missing GLIBCXX_3.4.14. My latest version is 3.4.13. Anyone know how to get the latest?

I tried to update my libstdc++, which glibcxx is part of. But i’m getting conflict errors, looking more into it as we speak.
Which are “libstdc++6-4.4-dbg : Conflicts: libstdc++6-4.3-dbg but 4.3.5-4 is to be installed” and
“libstdc++6-4.4-doc : Conflicts: libstdc++6-4.3-doc but 4.3.5-4 is to be installed”. Which makes no sense at all.
EDIT: Got it to update with, apt-get -f install libstdc++6-4.3-doc libstdc++6-4.3-dbg.
EDIT: srcds is still giving me the error: version `GLIBCXX_3.4.14’ not found (required by bin/libsteam.so)
Couldn’t LoadModule lua_sharedCouldn’t LoadModule lua_shared
EDIT: installing gcc++, which is 800 mb. Report back in a little
EDIT: I just realized i installed libstdc++6.4.3, force installing 6.4.4 with
apt-get -f install libstdc++6-4.4-doc libstdc++6-4.4-dbg
EDIT: I tried apt-get isntall libstdc++ again, now it’s saying it has to install 4.3.5-4, which is a lower version
EDIT: I’m gonna try force installing the giant list that libstdc++ updates for you
Note, selecting ‘libstdc++6’ for regex ‘libstdc+’
Note, selecting ‘libstdc++6-4.3-dev’ for regex ‘libstdc+’
Note, selecting ‘libstdc+±dev’ for regex ‘libstdc+’
Note, selecting ‘libstdc++6-4.4-dev’ for regex ‘libstdc+’
Note, selecting ‘libstdc++5’ for regex ‘libstdc+’
Note, selecting ‘libstdc++6-4.3-dbg’ for regex ‘libstdc+’
Note, selecting ‘libstdc++5-3.3-dbg’ for regex ‘libstdc+’
Note, selecting ‘libstdc++5-dbg’ for regex ‘libstdc+’
Note, selecting ‘libstdc++6-4.0-dbg’ for regex ‘libstdc+’
Note, selecting ‘libstdc++6-4.1-dbg’ for regex ‘libstdc+’
Note, selecting ‘libstdc++6-4.2-dbg’ for regex ‘libstdc+’
Note, selecting ‘libstdc++6-dbg’ for regex ‘libstdc+’
Note, selecting ‘libstdc++6-4.3-doc’ for regex ‘libstdc+’
Note, selecting ‘libstdc++2.10-dev’ for regex ‘libstdc+’
Note, selecting ‘libstdc++2.8-dev’ for regex ‘libstdc+’
Note, selecting ‘libstdc++2.9-dev’ for regex ‘libstdc+’
Note, selecting ‘libstdc++2.9-glibc2.1-dev’ for regex ‘libstdc+’
Note, selecting ‘libstdc++3.0-dev’ for regex ‘libstdc+’
Note, selecting ‘libstdc++5-3.3-doc’ for regex ‘libstdc+’
Note, selecting ‘libstdc++5-doc’ for regex ‘libstdc+’
Note, selecting ‘libstdc++6-4.0-doc’ for regex ‘libstdc+’
Note, selecting ‘libstdc++6-4.1-doc’ for regex ‘libstdc+’
Note, selecting ‘libstdc++6-4.2-doc’ for regex ‘libstdc+’
Note, selecting ‘libstdc++6-doc’ for regex ‘libstdc+’
Note, selecting ‘libstdc++6-4.3-pic’ for regex ‘libstdc+’
Note, selecting ‘libstdc++6-4.4-dbg’ for regex ‘libstdc+’
Note, selecting ‘libstdc++6-4.4-doc’ for regex ‘libstdc+’
Note, selecting ‘libstdc++6-4.4-pic’ for regex ‘libstdc+’

EDIT: Tried updating it with, apt-get -f install libstdc++6 libstdc++6-4.3-dev libstdc+±dev libstdc++6-4.4-dev libstdc++5 libstdc++6-4.3-dbg libstdc++5-3.3-dbg libstdc++5-dbg libstdc++6-4.0-dbg libstdc++6-4.1-dbg libstdc++6-4.2-dbg libstdc++6-4.2-dbg libstdc++6-4.3-doc libstdc++2.10-dev libstdc++2.8-dev libstdc++2.9-dev libstdc++2.9-glibc2.1-dev libstdc++3.0-dev libstdc++5-3.3-doc libstdc++5-doc libstdc++6-4.0-doc libstdc++6-4.1-doc libstdc++6-4.2-doc libstdc++6-4.3-pic libstdc++6-4.4-dbg libstdc++6-4.4-doc libstdc++6-4.4-pic libstdc++6-doc.
But it’s throwing errors that they aren’t available or referred by another package. Then the rest of them are saying no installation candidate. I’m out of ideas D:

What OS are you running im on debian lenny x64 and it only gives me up to libstdc++6-4.3.

I’m on Debian 6(lenny) x64

The exact error i’m getting: libstdc++6-4.4-doc : Conflicts: libstdc++6-4.3-doc but 4.3.5-4 is to be installed
I tried to install 4.3.5-4 but there is no package.

libstdc++6.4.4 should be on your debian apt-get http://packages.debian.org/squeeze/libstdc++6-4.4-doc

What is your /etc/apt/sources.list
Mine is:
deb http://ftp.us.debian.org/debian squeeze main
deb http://security.debian.org/ squeeze/updates main

Strange, I tried installing libstdc++6.4.4-doc again, it’s not there anymore.
Since i’m out of ideas, im gonna try installing debian 32 bit, since everybody that has problems seems to be running debian 64 bit.

Upgrading my ubuntu from lucid to natty fixed the problem

I guess I’ll try ubuntu, after gmod finishes downloading. I’m guessing your running ubuntu natty x64?

anyone know if centos works?

http://forum.i3d.net/hlds-valve-linux-newsletter/173257-hlds_linux-garrysmod-not-running-rhel-centos-5-a.html
I would take that as a no D:
Ok, same problem with debian 32bit, since my server provider doesn’t offer ubuntu 11.04 beta, I guess i’m going back to debian x64, and hopefully garry can do something.

this sucks.

Nope, running i386