Everyone can noclip [Edited server.cfg/Edited tab menu]

I’ve been asking for help but I haven’t got anything to work. I have edited the server.cfg to make noclip as 0. I restarted the server, it didn’t work. I went into the server settings in the tab menu as well and that didn’t work either. I don’t know any other options at this point. If needed, here’s my server.cfg file.

- - - - - -

// DO NOT SET A RCON PASSWORD IN HERE, A GMOD EXPLOIT CAN EXPOSE IT. USE THE COMMANDLINE.
log off

hostname “New RedemptionRP|FastDL|Need Staff|VIP|Fun”
sv_password
sv_region
sv_lan 0
sv_allowcslua 0
sv_log_onefile 0
sv_noclipspeed 5
sv_noclipaccelerate 10

//fastdl settings do not touch unless you know what you are doing
sv_downloadurl
sv_allowdownload 0
sv_allowupload 0
sv_loadingurl

mp_allowNPCs 0
sbox_godmode 0
sbox_playershurtplayers 1
sbox_noclip 0

// Server limits view the forum for wire limits
sbox_maxprops 100
sbox_maxragdolls 0
sbox_maxnpcs 0
sbox_maxballoons 0
sbox_maxeffects 0
sbox_maxdynamite 0
sbox_maxlamps 5
sbox_maxthrusters 0
sbox_maxwheels 0
sbox_maxhoverballs 0
sbox_maxvehicles 3
sbox_maxbuttons 0
sbox_maxsents 0
sbox_maxemitters 0

// Dont touch these unless you know what you are doing
net_maxfilesize 64
sv_minrate 100000
sv_maxrate 0

// execute ban files
exec banned_ip.cfg
exec banned_user.cfg

Got ulx? It might be a problem when it comes to stuff like this.

Uhhh… yea.

Edit the access of your usergroups.

Yea, I’ve looked at that as well and it doesn’t allow them to use it.

http://images.akamai.steamusercontent.com/ugc/277356179382446016/F0668DD7F40EA09C9757B17B5A3488356E9C1414/

Press tab and go to server settings.

You should see this on the right hand side

Make sure it say’s “Enable global noclip”

Sometimes fadmin and ulx like to disagree on what the settings are :stuck_out_tongue:

Yea. It’s like that. I tried that before but it still did not work. :confused:

creat module/allownoclip/sv_allownoclip.lua and add this


hook.Add("PlayerNoClip", "allownoclipscp", function(ply)
    if IsValid(ply) and (ply:Team() == TEAM_ONE                   
                or ply:Team() == TEAM_TWO
		or ply:Team() == TEAM_GANG
		or ply:Team() == TEAM_IA) then return true
    end
end)

Create those folders anywhere or in a specific already existing file?

Here?

darkrpmodification-master\lua\darkrp_modules/ and creat file allownoclip/sv_allownoclip.lua

fixed your image

need to take the url of the actual image, not the webpage

what ? all modif or add is to darkrpmodification- no gamemodes

Nope. . _. Didn’t work.

no possible you say sv_allownoclip is for your team you want have noclip add in all team allow

I found out that apparently when people bind " V " in the options menu, they’re still allowed to noclip. When people do it from console, they can’t. I don’t know what to do about that. Would that go along with the code you put above?

if u have extended ulx type !rcon sv_noclip 0
when u dont go to ur console ingame or gamepanel (for ingame type rcon_password [ur password] then rcon sv_noclip 0
in gamepanel basicly same

Tried that today. It didn’t work. . -.
Think I’ve tried everything at this point. Nothing is working… ._ .

Well, last thing u can do is reset ur files and reinstall everything, save the files u spend alot of time on

The owner and I have downloaded a backup file for it all. We did it yesterday night. We took out the addons and the files to see what was causing the problem. Nothing fixed it or was seeming to cause it. So, if it didn’t fix we just put the files back in.

Theres also sometimes a chance the cardealers get some codes stuxk, do u have any of those by any chancd?