Expected number, got "loop"

hello!
When i’m trying to compile this QC:


$scale "10"
$modelname "metro_2033\act_ameba_shar.mdl"
$cdmaterials "models\metro_2033"
$model "act_ameba" "act_ameba_shar.smd"
$sequence "idle" "act_ameba_shar.smd" fps 1
$collisionmodel	"act_ameba_shar.smd"

i obtain this:


Running studiomdl for "act_ameba.qc"...

qdir:    "d:\gmod models\metro 2033\"
gamedir: "D:\SteamLibrary\SteamApps\common\GarrysMod\garrysmod\"
g_path:  "D:\Gmod models\metro 2033\act_ameba.qc"
Building binary model files...
Working on "act_ameba.qc"
SMD MODEL act_ameba.smd
ERROR: d:\gmod models\metro 2033\act_ameba.qc(5): - expecting number, got "loop"

ERROR: Aborted Processing on 'metro_2033\act_ameba.mdl'
 ERROR: Compile of act_ameba.qc failed. Check the console for details
1 Errors and 0 Warnings
Error: Compile of act_ameba.qc failed. Check the console for details
"Compiled 0 Source SDK Base 2013 Multiplayer QCs" with 1 Errors and 0 Warnings
Info: "Compiled 0 Source SDK Base 2013 Multiplayer QCs" with 1 Errors and 0 Warn
ings

It’s a simple sphere-looking model (the amoeba from metro 2033), and two other models worked perfectly when i exported and compiled them the same way…
Any idea of what is causing this?

Remove the “fps 1” thing, you don’t need it for reference sequences.

I tried it, that fire the “line 5 is incomplete” error…

Try removing all the quotes, that may be breaking something.

EDIT: Yup, remove the quotes. The compiler is thinking that 10 is a string instead of a number.

It didn’t change anything :frowning:

Well then I don’t know what else to say.


$scale "10"
$modelname "metro_2033\act_ameba_shar.mdl"
$cdmaterials "models\metro_2033"
$model "act_ameba" "act_ameba_shar.smd"
$sequence "idle" "act_ameba_shar.smd" fps 1
$collisionmodel	"act_ameba_shar.smd"

wat, the sequence uses the same .smd file that the reference??? if thats true, export the reference into skeleton only and try compiling it again. Just in case…

[editline]18th May 2014[/editline]

into a separated .smd file

That’s perfectly fine, in fact it’s preferable. Saves space and no issue of skeleton mismatch.

But I just don’t get it. Where does it say loop? Maybe your SMD file is corrupt or broken? Try re-exporting your model.

I tried some really f*cked up combinations with the .qc and i didnt get this error with any sequence.
I think its the SMD, that may be badly exported.

BTW i thought that it could be the ref, because i had this error before and, i saw that in the sequence and changed into a skeleton sequence.
Maybe other thing fixed my problem in the past…

argh, sorry for that, messed up the result and the QC, that one give expecting number, got “fps”
Hopefully, that doesn’t change the problem :downs:
The problem about broken smd is that it’s directly exported from blender, which opened a obj exported from maya, which imported a kindoff-3d file format by the way of a specific plugin… what work for every other models i tried (aka gun and car from showcase thread http://i.imgur.com/regIDOl.jpg)
I tried reexporting the smd, after changing its size, also after changing its origin… didn’t change anything.

At this point it would just be easier to just upload your QC and SMD so we can see the problem ourselves.

.blend, .smd, .qc for one of the object (both give the same error)

Okay, what the heck is going on here. I honestly can’t figure it out. I’ll look at at it some more when I have time, it’s probably a syntax error.

EDIT: Aha! Right now the compiler is thinking act_ameba is the name of an activity, not an smd file. Change everything to just ameba instead.

Yep, that was it, thanks!