Experimental branch "Missing Executable" on Linux systems? (Steam)

I’ve tried to play the experimental branch on Linux. It appears that there’s no executable available. Is the experimental branch only being developed on Windows? (I’ve played it in Windows without the error). Will the new Rust version still support Linux? (assuming & hoping so).

BTW, love the game Garry. You guys have some great ideas. Can’t wait til the new version is playable in SteamOS :slight_smile:

It hasn’t been compiled for Linux the experimental branch. KDE > Gnome 3 anyday bud.

Thanks “bud”. Never said anything about Gnome :slight_smile: So experimental isn’t compiled for Linux, are there plans to do so? Would hate to see the game lose Linux support.

I don’t know where you get your info…

Workaround…

May 5

I tried renaming the folder as mentioned in the workaround. I’m still getting the same error in Steam. “Failed to start game (missing executable)”. BUT I did notice that I could go to the “~/.local/share/Steam/SteamApps/common/rust” folder and run “./Rust” and the game indeed starts up. But currently doesn’t show any servers available (assuming they are down for development reasons). Not sure why Steam still thinks the executable is missing. Maybe another case sensitive thing?

FYI from what I can tell the Linux version is looking for “rust.x86”. If you just run “Rust” it should work.

Sure would help if Steam would do that for us :slight_smile: But it does work to run ‘Rust’ manually. Good enough solution for now.

Still not seeing servers though…

I am also running it on Ubuntu Linux (by manually starting Rust after renaming the data folder) but I can’t see any server either.

[editline]13th May 2014[/editline]

Just a moment ago Garry added errors logging and I get this one:

DllNotFoundException: SteamNative



Steam.Client.Init ()
SteamClientComponent.Awake ()
UnityEngine.Object:Instantiate(Object, Vector3, Quaternion)
GameManager:CreatePrefab(String, Vector3, Quaternion)
c__Iterator2:MoveNext()


Could it be somehow related to the servers issue?

Just a shot in the dark but you mention you all run it through the command line bypassing steam. Does that mean possibly its not getting white listed by steam into your firewall rules? Maybe you will have to whitelist it manually.

It is much simpler than all that.

https://pbs.twimg.com/media/Bnjhot2IEAAtrd8.jpg

EDIT:
Renaming Rust to Rust.x86 will allow you to launch rust from steam, but get the same error in console.

SteamOS uses Gnome 3.

Well, I renamed Rust to Rust.x86 but hitting the Play button in Steam will not start the game. I only see the “Preparing to launch Rust” dialog for a second and that’s it. So, I have rust_Data renamed to Rust_Data and Rust renamed to Rust.x86 yet the game won’t start from Steam.

Logs from Steam:

content_log.txt


[2014-05-14 12:36:22] AppID 252490 state changed : 0x00002004 = Fully Installed,App Running,
[2014-05-14 12:36:22] AppID 252490 state changed : 0x00000004 = Fully Installed

stats_log.txt


[2014-05-14 12:38:24] [AppID 252490] CAPIJobStoreUserStats::BInit() - no stats found, aborting

These are the only logs that change after I click Play

I too am seeing the “Need Steam” error in console. So I guess that explains why we don’t see any servers. Oh well. At least we have a bead on what’s generally going on here. I’m sure we’ll see a fix sooner or later.

https://twitter.com/garrynewman/status/466458811273084928

Thank you for your efforts buddy!

Well, the fact that Garry doesn’t keep his word is not a surprise. It is nice to see how they send 2 or 3 updates per day but is so frustrating to not be able to test them.

I think we’ll have to give him some benefit of the doubt. He’s been pretty busy putting together his grand vision. If you think about the development process and the efforts involved its easier to be patient. The main thing we can do for now is keep the reminder going. Your reply helped with that. Thanks :slight_smile:

IF you look at the new files he did change them, however I dont think it solved anything becasue now I cant launch the game at all.

Time to investigate!