Expression 2 screws up on loading saved files

This is a strange one. When I spawn a Expression 2 which is validated in game, it gives me no errors, and runs well. However, after I save the game and load it up again, it would give me these errors:

entities/gmod_wire_expression2/core/core.lua:28: attempt to compare nil with number
entities/gmod_wire_expression2/init.lua:112: attempt to perform arithmetic on global ‘e2_softquota’ (a nil value)

Additionally, the expression 2 that was working well earlier would turn red (signifying a error) and would not work.
A picture: http://img39.imageshack.us/img39/2995/errorgm.jpg

The reason I have 200 health is that I installed some addon. I have the latest version (1776) of Wire and the model pack for wire as of this post

Any help or assistance would be appreciated. Thanks.

Saved games have always been fucked. Use the Advanced Duplicator instead.

Do you mean that it is not working for you too? Any ideas as to what might be causing the problem?

I don’t know if it’s working or not. Never tried saved games.
And I have no idea what’s causing it, but I do know that Garry won’t fix it.

hmm… now that you mention it, I suppose using the advanced duplicator would be much more useful. Thanks for the advice! Do let me know if the problem is solved though, it would be mighty helpful :slight_smile: