Extracting models from a unity game?

don’t have the original files anymore or the .unity3d file, can play the game fine but all i’ve been able to do is get textures, is there anyway to get models out?

You could try NinjaRipper

i’ve tried 3d ripper dx, ninja ripper, 3dvia printscreen, and game assassin all they get is textures if anything

As long as the game you’re wanting to extract from isn’t running on the latest build of Unity (which I think is version 5, if memory serves me right), you can use a program called DisUnity to extract the model and texture files from the game in question.

okay i downloaded DisUnity but have no idea how to use it

[editline]1st August 2015[/editline]

the .bat file won’t stay open for me to even attempt any commands like tutorials say, it closes as soon as i open it

You’re running Disunity through Command Prompt and you’re still not getting anything?
What exactly did you type in the Command Prompt?

i can’t type any commands, the command prompt closes within seconds after opening

Are you running as an administrator?

just tried, does the same thing

If you press Shift and Right-Click in the folder where Disunity.bat is located, then find “Open command window here” and go from there.

okay thanks! the only files i can even think i could try to extract from is “mainData” no file extension, “sharedassets0.assets” or “sharedassets0.resource” i don’t have a .unity3d file, i’ve never extracted anything or attempted to extract anything this way before

The “sharedassets” extension can be extracted, although it’s preferable to import them into 3DS Max with the help of a script. Some models/textures are packed in a way that separates them into multiple parts, so if you extracted the sharedassets individually, some files would be “incomplete”.

idk what to type in the command prompt to get it to try to extract from anything

“Location\of\disunity\disunity.bat -extract location\of\assets\files\whatever.sharedasset”
Without the quotes.
It’s preferable to make separate folders for each sharedasset file, so nothing may get overwritten.

it errors with the - typed before the extract location (i’m actually typing the extract location, not just typing “extract location” literally), and i don’t understand the \ in between location\of\disunity like that, i assume just the location of disunity\disunity.bat though correct

[editline]2nd August 2015[/editline]

i doubt this is what i’m supposed to extract from anyways, all the .assets files are only 3 KB in size

[editline]2nd August 2015[/editline]

nevermind for some reason the 1 i made a copy of ended up being that, the one in the game files is bigger, i’m trying the 3DS Max method now, but once i install the script, when i pick load file, pick to load the .assets file, i assume i would pick to “Import Selected” but when i do nothing loads or imports at all

i’ve even tried this UnpackAssets script for Unity, just gives me an empty folder when i pick to Unpack

If you open the “Readme.md” file with a text editor (or change the extension to .txt), it’ll show you example commands for Disunity.

and does not work, always just says “is not recognized as an internal or external command, operable program batch file.” whether typing “c” “-c” “extract” “dump” or any of the commands listed

[editline]3rd August 2015[/editline]

those are specifically the parts it says is an unrecognized command

[editline]3rd August 2015[/editline]

got it to work with no errors and all it does is just turn the Sharedassets0.assets file from 117,294 KB to 3 KB for whatever reason, that is all i can get it to do, before extracting = 117,294 KB in size, after extracting = 3 KB in size, but still the same exact file type

you can use 3dx ripper to extract from web builds on the web browser
first open the 3dx ripper and select the browser that you want to run
second go fast to the game web build :facebook apps or other sites where they are uploaded and you will se a ready thing from the 3dx ripper than you can rip when the game started for the browser

the game isn’t in any browser it’s a downloaded .exe

[editline]3rd August 2015[/editline]

i’ve already tried every 3d ripping tool i can think of on the .exe already, none work with it, Ninjaripper only gets Textures