Extreme Brightness

I’m having an issue where every map I compile is extremely bright, regardless of the different settings I’ve tried.

For instance, about 2 months ago I made and compiled this map:

Now, I’ve reloaded the .vmf (note that I changed nothing with the map, it’s exactly the same as it was when it was working properly) and now that same area looks like this:

I’m not sure what’s going on, can anyone shed some (dimmer) light on this issue?

This occurs on any map, not just the one above.

Post the compile log so we can get more details and check for errors.

Sure thing:

And Hammer settings:

I’m not too concerned about the missing texture messages as they show up fine in-game, though those errors weren’t there when I compiled before.

When Hammer reports missing textures, it cannot compile lighting data for them, that`s probably the reason for the extreme brightness.

I’ve been looking through the settings and can’t seem to find any reason why it shouldn’t be finding the textures. It looks like it’s looking in the right directory, the textures show up fine in Hammer’s 3D preview and texture browser, and again nothing in the map file or program settings changed between a couple months ago when everything worked fine and today where I’m getting this.

I’ve seen this sometimes help if you select the entire map, copy it, then open a new vmf and paste special, so that everything is kept. Sometimes it loses its texture directory for the vmf.

You’re also sure the materials are in “E:\Steam\SteamApps\common\GarrysMod\garrysmod\materials\worlds\building01” for example?

I just tried copying it all to a new vmf and trying it there but still the same issue.

And yeah all the texture files are where they’re supposed to be:

It all looks perfectly fine in Hammer:

Make sure to doublecheck the vmt and vtf files are in a directory hammer’s looking for as well, not just for gmod. (I use CS:S Hammer to build gmod maps, so I have a custom director both in the CS:S directory and gmod, and without it being in the CS;S directory, hammer can’t see it.) The errors in your compile log are stating that regardless of where your files are, the compile programs cannot find them.

Another thing to check is if you’ve reinstalled hammer recently, your gameinfo files for hammer may be missing the line to check your custom directory.

Also, try compiling without HDR and see if it remedies the issue.

I’ve been using Source SDK Base 2013 Multiplayer Hammer and building programs. The gameinfo.txt for the game seems to be as it should be, and the GameConfig.txt for Hammer looks right too:

I haven’t reinstalled the files since the last time it worked, but I just tried deleting Source SDK Base 2013 Multiplayer’s content and removing the remaining files, then redownloading it and setting it up again and still have the same issue. I also tried compiling it without HDR but that just makes it fullbright:

But yeah Hammer and the game are finding the textures just fine, but the compiling programs seem to be having some kind of issue (vbsp in particular). Even after redownloading the files I’ve verified the content again to no effect.

Normal non-HDR compiling into fullbright is also indicative of a problem. Check your commandline options for VRAD.

Hmm well here are the settings I used during compiling:

LDR:

HDR:

If anyone has a copy of the Source SDK Base 2013 Multiplayer vbsp.exe, vvis.exe and vrad.exe files that they know to be currently working, I would be appreciative if they could be shared, if nothing else it will help me to eliminate them as possible culprits.

OK, so I forgot that I had a custom fix for this that I use myself for Hammer. Find gameinfo.txt in the garrysmod directory and find this line


mod+mod_write+default_write_path		|gameinfo_path|.

and replace it with


game+mod_write+default_write_path		|gameinfo_path|.

This should fix missing materials in vbsp and fullbright materials as well. :v:

Thank you, that solved the problem :smiley:

You just made my life much easier ^.^