Extremely Annoying FPS Studder Bug with Realtek Audio - URGENT

First of all I’d like to stay that I’ve been enjoying the game alot on one of my computers. It runs it 100+ frames on fantastic easily. The problem arrises when I move over to my laptop to play. I’m able to max out the settings and resolution with grass off with 80 frames yet 2-4 times a minute there is a 1-3 second freeze in where the sound repeats, the screen freezes and you cannot move. I know they’re are fixes from users to disable your Realtek audio and I agree that fixes it but I believe this is unacceptable as I actually listen to other things while playing.

I understand that this game is in Alpha but when it comes to a bug caused by an onboard soundcard that MANY players are using (I say over 50%) this is losing everyone money. If anyone does have a fix that does not include disabling the audio completely, feel free to post it here. I really hope Garry views this and is able to debug it in the next patch because I cannot play this game on my laptop because of it. I used some good keywords to get people with this problem to search it. I hope I can help as many people as possible with this.

Specs:

i7 4600MQ @ 3.6GHz
NVIDIA GTX 770M 3GB
12GB 1600MHz
Onboard Realtek Audio
120GB Samsung SSD
1TB HDD

What are your laptop’s specs?

Edited in my computers specs, I do not think that is the issue, many posts say it is the Realtek audio causing the problem.

Do you have netlimiter installed?

There’s alot of things that can cause a stutter every 3 seconds

Many of the people that read this problem think this is a personalized problem, its nothing that he or anyone else is doing, this is a problem caused by some error in the game that is somehow connected to Realtek Hd Audio. I haven’t seen any official postings about this problem although i see a great number of people experiencing it. This strikes me as strange when the “Auth Failure” issue was posted almost immediately as it occurred. Grated not getting into the game at all is more important than lag spikes, these spikes are just are detrimental as it causes it to be unable to pvp or even pve against zombies(In my case the spikes happen every 5-10 seconds lasting for up to 3 seconds). If any forum mod/admin sees this, could you please make this an official thread so we can start pooling our information and hope to solve this problem, instead of making dozens of small threads that do nothing to help.

I don’t think it’s the issue either, but until you told me what your specs were, I had no way of knowing whether or not that was the case.

already had the problem after whining about it on forums and getting no answers I decided to go on my own and do some research, heres a couple of fix ideas

fix 1:http://forum.facepunch.com/showthread.php?t=1329363
fix 2:right click on the little volume icon on the bottom right of the screen and click playback devices ,afterwards set speakers as the default playback device head over 1 tab to the right and select stereo mix as your default recording device.

if this doesn’t work do not be afraid to PM me and/or post on this thread

Just tried that but it seems to have had no effect, do you know anything else that might help?

I had the lag stutter as well, but fixed it after about an hour messing with my drivers and relogging to test.

I also encountered the issue of having two audio drivers installed, that was stated in the aforementioned post above.
Though I had to remove the register keys and reinstall my audio drivers too to get the lag stutter to stop.

Basic steps included, with guide!
My instance of fixing this issue:

  1. Uninstall Nvidia audio drivers from device manager
    1a. Navigate to: Device Manager->Audio->Nvidia High Definition Drivers, right click->uninstall

  2. Uninstall Nvidia audio drivers from Programs
    2a. Navigate to: Control Panel->Programs->Nvidia Audio (I had two different types installed)->uninstall

  3. Remove all instances of Nvidia audio drivers from registry
    3a. Navigate to: command prompt->type “regedit” (no quotes)-> HKEY_CURRENT_USER->Software->Nvidia->Remove all instances of audio drivers

  4. This step may not necessary for u, test for the stutter ingame before you take this step!
    4a. Reinstall updated Audio Drivers from manufacture of your computers site (I have a laptop, so it might be different for u… soundcard’s site if u have one, or motherboards site if you don’t have a sound card)

Hope this helps some1 get a better play session!

I have this problem, 1-3 second client side lag every few minutes or so. Can’t disable Realtek Audio unless I want to lose all audio on my laptop, and not going to mess around with the registry for a $20 game.

I had the Realtek bug but plugging in a USB headset some how fixed the stuttering. I also disablef nvidia audio and high definition audio under the device manager

Bumping this again, I tried all of the fixes here only disabling the realtek audio fixes it. Please sticky this so a dev can see this i’m sure this is happening to many people.

Bump.

Bump.

BUMP I NEED A FIX FOR THIS.

I have IDT, not Realtek, and this happens to me. The screen frequently freezes and sounds repeat 3 times. The only solution is disabling the sound card, but then I can’t hear people shooting at me, talking to me, or sneaking up behind me.

Bump!


(User was banned for this post ("Bumping" - Craptasket))