FA:S 2, Recompiling models

Hello.
I’ve been trying to add FA:S Weapons to my Dark-rp Server on GMOD, But for some reason, When i try and look at them, they look like CS:S Models, and not like the actuall models, And apperantly it happens to alot of people.
Is there any way of fixing that?
I tried looking in the script, and it says this:
“SWEP.WM = “models/weapons/w_ak47.mdl”
SWEP.WorldModel = “models/weapons/w_rif_ak47.mdl””
so the first wordmodel will be defined as your world model, and but second one will be as a CSS Model, can you explain that please?
In addition, i tried changing the SWEP.WM to the SWEP.WordModel, sometimes it works, and sometimes it doesn’t, If I try and spawn a model which wont work, when it spawns, it creates a green circle around it.
I looked it up, And the green circle means it an effect, not an actully prop/model.
Is there anyway I can recompile the models, and make them as a prop/model?
If there is please let me know how, so i can start doing so.
Thanks for all helpers!

Can you post the code?

What code?

why not just use the sweps that come with it?

As i stated they are being spawned as a CS:S Model, isntead of thier own.

The code to the weapons you’re trying to make work…

Yea, but which part should i put in? it has alot of lua files…
As i told you the problem is in some of the models spawning as an effect…
and btw this is the code for one of the guns.


if SERVER then
	AddCSLuaFile("shared.lua")
	SWEP.ExtraMags = 4
end

if CLIENT then
    SWEP.PrintName = "AK-47"
    SWEP.Slot = 3
    SWEP.SlotPos = 0
	
	SWEP.AimPos = Vector(-2.201, -4.646, 0.675)
	SWEP.AimAng = Vector(0.264, 0, 0)
	
	SWEP.CompM4Pos = Vector(-2.181, -2.5, -0.203)
	SWEP.CompM4Ang = Vector(0, 0, 0)
	
	SWEP.MuzzleEffect = "muzzleflash_ak47"
	SWEP.Shell = "7.62x39"
	SWEP.AttachmentBGs = {["compm4"] = {bg = 3, sbg = 1},
		["suppressor"] = {bg = 2, sbg = 1}}
		
	SWEP.WMAng = Vector(0, 180, 180)
	SWEP.WMPos = Vector(1, -3, 0.25)
end

SWEP.Attachments = {
	[1] = {header = "Sight", sight = true, x = 800, y = -50, atts = {"compm4"}},
	[2] = {header = "Barrel", y = -200, atts = {"suppressor"}}}

SWEP.BulletLength = 7.62
SWEP.CaseLength = 39
SWEP.EmptySound = Sound("weapons/empty_assaultrifles.wav")

SWEP.Anims = {}
SWEP.Anims.Draw_First = "deploy"
SWEP.Anims.Draw = "deploy"
SWEP.Anims.Holster = "holster"
SWEP.Anims.Fire = "fire"
SWEP.Anims.Fire_Aiming = "fire_scoped"
SWEP.Anims.Idle = "idle"
SWEP.Anims.Idle_Aim = "idle_scoped"
SWEP.Anims.Reload = "reload"
SWEP.Anims.Reload_Nomen = "reload_nomen"
SWEP.Anims.Reload_Empty = "reload_empty"
SWEP.Anims.Reload_Empty_Nomen = "reload_empty_nomen"

SWEP.Sounds = {}
SWEP.Sounds["reload"] = {[1] = {time = 1, sound = Sound("Weapon_AK47.MagOut")},
	[2] = {time = 1.5, sound = Sound("MagPouch_AR")},
	[3] = {time = 2, sound = Sound("Weapon_AK47.MagIn")}}
	
SWEP.Sounds["reload_nomen"] = {[1] = {time = 0.6, sound = Sound("Weapon_AK47.MagOut")},
	[2] = {time = 1.2, sound = Sound("MagPouch_AR")},
	[3] = {time = 1.8, sound = Sound("Weapon_AK47.MagIn")}}
	
SWEP.Sounds["reload_empty"] = {[1] = {time = 0.7, sound = Sound("Weapon_AK47.MagOutEmpty")},
	[2] = {time = 1.15, sound = Sound("MagPouch_AR")},
	[3] = {time = 1.85, sound = Sound("Weapon_AK47.MagIn")},
	[4] = {time = 2.9, sound = Sound("Weapon_AK47.BoltPull")}}
	
SWEP.Sounds["reload_empty_nomen"] = {[1] = {time = 0.8, sound = Sound("MagPouch_AR")},
	[2] = {time = 1.5, sound = Sound("Weapon_AK47.MagOutEmptyNomen")},
	[3] = {time = 1.8, sound = Sound("Weapon_AK47.MagIn")},
	[4] = {time = 2.5, sound = Sound("Weapon_AK47.BoltPull")}}
	
SWEP.FireModes = {"auto", "semi"}

SWEP.Category = "FA:S 2 Weapons"
SWEP.Base = "fas2_base"
SWEP.Author            = "Spy"

SWEP.Contact        = ""
SWEP.Purpose        = ""

SWEP.ViewModelFOV    = 60
SWEP.ViewModelFlip    = false

SWEP.Spawnable            = true
SWEP.AdminSpawnable        = true

SWEP.VM = "models/weapons/view/rifles/ak47.mdl"
SWEP.WM = "models/weapons/w_ak47.mdl"
SWEP.WorldModel   = "models/weapons/w_rif_ak47.mdl"

-- Primary Fire Attributes --
SWEP.Primary.ClipSize        = 30
SWEP.Primary.DefaultClip    = 60
SWEP.Primary.Automatic       = true    
SWEP.Primary.Ammo             = "7.62x39MM"
 
-- Secondary Fire Attributes --
SWEP.Secondary.ClipSize        = -1
SWEP.Secondary.DefaultClip    = -1
SWEP.Secondary.Automatic       = false
SWEP.Secondary.Ammo         = "none"

-- Deploy related
SWEP.FirstDeployTime = 0.45
SWEP.DeployTime = 0.8
SWEP.DeployAnimSpeed = 0.5

-- Firing related
SWEP.Shots = 1
SWEP.FireDelay = 0.1
SWEP.Damage = 34
SWEP.FireSound = Sound("FAS2_AK47")
SWEP.FireSound_Suppressed = Sound("FAS2_AK47_S")

-- Accuracy related
SWEP.HipCone = 0.048
SWEP.AimCone = 0.006
SWEP.SpreadPerShot = 0.008
SWEP.MaxSpreadInc = 0.03
SWEP.SpreadCooldown = 0.18
SWEP.VelocitySensitivity = 1.8
SWEP.AimFOV = 5

-- Recoil related
SWEP.ViewKick = 1.3
SWEP.Recoil = 0.9

-- Reload related
SWEP.ReloadTime = 2.6
SWEP.ReloadTime_Nomen = 2.2
SWEP.ReloadTime_Empty = 3.3
SWEP.ReloadTime_Empty_Nomen = 3

that’s because there are no worldmodels.

[editline]6th March 2014[/editline]

If you want you could just use your own worldmodels for the ones that lack an FAS:2 one.

There are world models, i saw them…
The only thing that is wrong with them, is that they are classifyed as an effect, and not as a model, But they are a model, cuz i can spawn them in-game.

there are SOME worldmodels. Not all of them are in yet and not all are complete.

well i’ve seen most of them…
I’ve seen almost each and everyone of them, like for the ak’s.
But when i try and spawn them, its an effect, and not a model it self.
They did intend to make it as a model, but its somehow spawned as an effect…
I need to know why, or how to make it spawn as a model instead.

Because it’s not compiled as a physics object
you don’t need to make it spawn as a model, spy parents it to the right hand on the player to act as a pseudo world model and it’s likely that he has it parented to CSS weapons in-world that DO have physics objects.

Im talking about the weapons when they are being dropped.

FA:S 2 doesn’t really have world models, the reason why it floats around or w/e is because there is no collision.

But i got the World models when i spawn them…
But for some reason it spawns as an effect, there is a world model for an ak47.
By the way, if i go to single game, it works perfect… so the world models works.

You’re missing the thing we’re all saying.

Yes, there are world models, but the world models don’t have collisions.

They are parented to the hands using one of several various methods of Lua fuckery, instead of the usual (and better) way where they are compiled with proper bones and collisions.

You would need to decompile all of the world models that lack them, and go into a modeling programme and make a new collision, add bones, and then recompile the models with their collisions & bones before they would work correctly.

so why does it work in single player? but in a server where the Dark-RP Mod is installed it doesn’t work?
When i try and spawn the weapon in single player, it shows the world model that they made, but on the dark-rp one it doesnt.
And isn’t adding bones is a already a View model?
Just to make sure a World Model is the model that shows when you drop it.

It is.
How are you dropping it in DarkRP?

/drop, just dropping it regulary.
I dont get it…
I understood what you guys said, but it works on single player… so thats wierd.

Did you try it in DarkRP singleplayer or sandbox