Failed to load sound "" (v2) - ( Posted in wrong section before.)

Hello.
I still got the problem.

It’s not that easy that its just because it can’t find the sound.
The sounds works, but after a while, it suddenly says it can’t find the sounds. ( I guess that music/HL2_song20_submix0.mp3 is a file which is included in HL2)

Its like… I hear the sound, music/HL2_Song20_submix0.mp3 … After a while, it suddenly won’t play any sounds, but says "Failed to load sound “” "

I tried to ask for help here before, but my thread got locked with a post that sounds like someone misunderstood my point. (Like that it was just me who made a script that tried to play a “” sound.)

Could you please help?

Sorry for my noobish doubleposting, but i posted in the wrong section by accident. (Posting it in here instead.)

Could someone please help me? It also says that it can not load color correction files ‘’

Its like that it can’t find any files. This is happening to other people than just me. Does anyone know what to do?

And no one can help me? Please?
At least if you are confused about something in my question, just ask.

Does the file actually exist?

[editline]27th October 2011[/editline]

type this in console;



lua_run_cl surface.PlaySound("sound");


and see if it can play the sound.

[editline]27th October 2011[/editline]

replace sound with the path to your sound

[editline]27th October 2011[/editline]

or use the ‘play’ command in console

The file does exist… since when i restart gmod, it can play the sound just fine. (And i guess that music/Hl2_song29.mp3 IS a soundfile that exist, since i could play it when i restarted gmod.)
Then later, it bugs again.