Failed to load the launcher DLL

After downloading an update and attempting to launch Garrysmod, I get this error:

it’s giving me the same error on another computer as well. Is Garrysmod broken for the time being cause of this update?

Restart steam maybe?

Im getting it too, and I’ve tried restarting steam.

latest source engine update broke the game

Noticing more and more players on my server messaging me about this.

Is there any article that Garry or Valve has posted yet?

well it’s anywhere from like 2-5am for garry (I don’t know specifically) right now lol

and it’s not valve’s game, they don’t give a shit (sadly)

oh my god why did I do this again
stupid enough to not fucking check the forums, I reinstalled the game

Seems like the GMOD 13 beta isn’t working either.

Really? I thought Garry’s Mod 13 was supposed to be using it’s own independent version of the engine.

This is happening to me too.

i restarted steam and other stuff. nothing happens

Not the same thing that is happening to GMOD.

We just got to wait until Garry fixes both the Steam Release and Gmod 13.

Let me get Midnight Club LA…

[editline]27th June 2012[/editline]

All we have to do is wait until Garry Patches Steam Gmod and Gmod 13

Atleast I still have my gmod up!

Even though it won’t be any help, same error is happening for me too.
Anyone have an ETA of when the game will work?

Damnit. I wish I set it to Do not update automatically.

when garry gets to work, no sooner.

Damn, getting the same error.

So I finally decided to stick SRCDS on my box and host a Stronghold server, and this happens. Time to swap it over to TF2 and download via SRCDS. :3

Guess Who’s here to stalk you some more! HEHEHEHEHEHE

Anyway, should i not download the new patch then?