failed to lock index buffer in CMeshDX8::LockIndexBuffer

Notice that this is now “failed to lock index buffer” rather than “failed to lock vertex buffer”

This seems to be happening under the same conditions as the vertex problem (almost randomly midgame), though this time I’ve only experienced it in Gmod. According to Steam support this happens when you alt+tab and don’t have enough memory to render graphics or something, but the thing is I’m not alt+tabbing and I’ve set the heapsize to 1024000 kb (I have 2gb RAM). I’m at a loss ad to what is causing this. Help?

I have this problem also.

I also have the same problem, but I get this error when launching the game. I get the load screen image, but then the error. A bit of a letdown I’ve gotta say. I e-mailed Garry the crash logs, and a little description. If I hear anything about a solution, I’ll post it here.

Well, since it’s a Direct X 8 error, you should try Direct x 7, or 9, or another one.

I get failed to lock vertex buffer when I try to load a certain map.

This happens to me on some Counter Strike: Source maps (especially cs_milita) and all Day of Defeat: Source maps

This doesn’t happen to me because of maps, it happens when loading GMOD. I tried a few start up options like to use DX 7,8,9 to test those, strangely enough it gave me the exact same message for each one, like it didn’t change anything.
Still no response from Garry since I sent him crash logs.

I have this exact problem. I paid $10 for this, and I haven’t gotten to play it at all.

This is a problem, one that must be solved. All of us could use a solution.


For me, it’s “Start game…Black screen appears like its loading… game dies”
Warning appears, and this didn’t happen untill approximatly, 3 days ago.

1198 people were viewing this when I came on:
And so far, only 8 replies.
But I will post if I hear anything about the solution. I know how it feels to really want to play a game that doesn’t work (hint hint Bioshock)

i get the same exact problem as lunchboxl33t…and then a msg box that says “The instruction at ‘0x0ff03e2c’ referenced memory at ‘0x0e3fa1a0’. The memory could not be ‘read’. Click on OK to terminate the program [ok]”.


i dont even get to start the game…double click it, black screen appears, crashes, error msg’s.

i fixed it

Oh thank the maker!

^Kudos to whoever gets where that’s from.
Trying now.

So I won’t be able to carry on with Episode 1 unless I edit my registry key thingy which I’m not so keen on or wait for valve/steam to fix it?

what about cs_milita? its one of my fav maps and i tried Dx thing and the thing in the link and i still get the failed to lock index buffer error PLEASE HELP IM DESPRATE

I HAVE THE SAME PROBLEM WILL SOMEONE FIX THIS STUPID BUG iv got the start up version of it, like some i just baught it and from what iv read it seems to happen on counter strike source in zombie mode and on garrys mod. Someone really needs to get this SORTED. I sent the message to steam support but so far iv had no reply, i will try turning down the grafics but some how i dought that will work. SOMEBBOODDYYSAAVVEEUSSS SOS!!


I only have this problem “Failed to lock Vertex buffer problem” in cs_militia. I don’t know what the problem or solution is, but I’ve found a way to bypass it.

But first, this method only works in singleplayer. So if you want to play cs_militia in multiplayer, you’re out of luck.

Alright, here is how I bypassed the problem:

  • When I load the map, I have about ten seconds before the game crashes.
  • Before it crashes, I save my game.
  • The game crashes, and I start up Garry’s Mod again.
  • I load from my saved game, and it works. It never crashes again.

Since then, I’ve put about 15 hours on that map alone, always loading from my saved game. I never crash. The only time I do crash is when I refuse to load from my saved game.

I hope this works for you.

WOW, finally!

Thank you so much. <3
Insurgency maps, here I come!

This happens every time I load rp_evocity2_v2p. I tried all the methods, but they didn’t work. I don’t get the engine error annymore, but it’s gotten so bad that it crashes before it finishes loading.

this happens to me to. can someone help?