"Failed to lock vertex buffer in CmeshDX8::LockVertexBuffer" What?

This error is bugging the shit out of me, when I load certain maps like cs_militia and custom maps like the COD4 one, I get it.

http://img4.imageshack.us/img4/320/94963746.jpg

Nobody else suffers this error?

I get it but only on evocity2.

Maybe it has to do with your video card.

God this error is pissing me off so much. I loaded the maps in CS:S and they run great, but in GMod they fail. I’ve deleted the local content for both and redownloaded, starting from scratch in both, and still the error continues.

I have a 9500GT with the latest drivers on all of my hardware.

WHY IS THIS HAPPENING TO ME?!

Most CS maps cause the same error, and in my poses I tend to use CS maps.

It USED to work great some time ago, so I know my graphics card is capable.

Yeah, I got the same problem. Haven’t found a remedy, yet.

Gmod pushes source to the limit. Here’s a small fact to prevent others from raging or likewise: Gmod pushes source to the limits, it does what source was never designed to do, and because of this it’s a resource hog. While it’s playable on CS:S, which runs on the HL1 engine, lower requirements etc, Gmod runs on the EP2 Engine, which already asks for more. With Gmod running on top of that, you’re pretty much pulling the engine apart.

To answer your problem, -dxlevel 80 in the command line should fix it. Don’t try running evo2, it’s a shit map.

[editline]11:53AM[/editline]

Also, ensure your graphic drivers are up to date.

halo is hakcing your severe!!!

Well, it didn’t fix it, but what ever. I guess I will reinstall Gmod 9 for posing in those maps.

It’s just odd because I recall those maps working [cs_militia especially] after the EP2 update for GMod

-dxlevel 70. Or if you really want to try, -autoconfig will reset Gmod to the default config.

I believe this can also happen if you have another thing in the background using alpha blending.

Try turning off Aero.

I Had this Problem Only with Nivada Video Card’s

Try all of the following

  1. Update your Video Driver’s
  2. Reinstall Garry’smod and all of the games
  3. Reinstall Steam then Reinstall Garry’smod

If that dosnt work there really isnt much of a better option then to get another video card

i have 1 more question, Are you using PCI or PCI express Video Card

If you are using PCI that could be your big issue

I am using an Nvidia 9500 GT which is PCI-E