Failed to open dedicated_srv.so

Hello,

I just updated one of my servers to the latest version of Garry’s Mod and I came across this error when starting the server:


Failed to open dedicated_srv.so (/lib/i386-linux-gnu/libm.so.6: version `GLIBC_2.15' not found (required by bin/dedicated_srv.so))

Would you guys be able to help me out with this? The server has been running fine for 4+ months and my 32 bit libs are up to date.

Server specs:
Debian 7
1GB RAM

Kind regards,
Djmaster329

Its the new gmod update did it up all waiting for a patch by the gmod team

How long will we have to wait until garry fix this error, what do you think? (I am getting the still error when I try to start my server, linux)

And as with CentOS?

reade here

Dint work for me sill get the same error

Failed to open dedicated_srv.so (/lib/i386-linux-gnu/i686/cmov/libm.so.6: version `GLIBC_2.15’ not found (required by bin/dedicated_srv.so))
Add “-debug” to the ./murder/srcds_run command line to generate a debug.log to help with solving this problem
Tue Jul 8 22:59:14 CEST 2014: Server restart in 10 seconds

Debian or CentOS?

debian

Mine was solved using this: http://forum.facepunch.com/showthread.php?t=1245705&p=45329603&viewfull=1#post45329603

[root@ts805 glibc-build]# …/configure --prefix=’/usr’
checking build system type… x86_64-unknown-linux-gnu
checking host system type… x86_64-unknown-linux-gnu
checking for gcc… no
checking for cc… no
checking for cl.exe… no
configure: error: in /root/glibc-2.15/glibc-build': configure: error: no acceptable C compiler found in $PATH See config.log’ for more details

CentOS

It looks like you don’t have a compiler installed, or it can’t find it.

Edit:
Try looking here and see if that helps.
http://sourceware.org/glibc/wiki/FAQ#What_tools_do_I_need_to_build_GNU_libc.3F

yum groupinstall “Development Tools”

Does the CentOS solution risk breaking things? I thought upgrading glibc to an unsupported version was supposed to cause loads of problems.

I once did it and borked my whole system. Your mileage may vary!

Yeah im just gonna wait this out.

Auto detecting CPU
Using default binary: ./srcds_linux
Server will auto-restart if there is a crash.
Failed to open dedicated_srv.so (/lib/libm.so.6: version `GLIBC_2.15’ not found (required by bin/dedicated_srv.so))
Add “-debug” to the ./srcds_run command line to generate a debug.log to help with solving this problem
Tue Jul 8 17:18:43 EDT 2014: Server restart in 10 seconds
^CTue Jul 8 17:18:47 EDT 2014: Server Quit

Doesnt fix my problem

Edited:

I updated and installed you glibc
and doesnt help

Edited:

You said to me to do
…/configure --prefix=’/usr’

Edited:

I did it …

Edited:

I tried to reconfigure with your options, doesnt work and didnt fix the problem…

This post from the FAQ thread

This would by why im waiting it out.

you ain’t waiting this out boy, this change is permanent, only thing you’ll get eventually is easier instructions and maybe a dependency script.

I appear to be getting this configure error when I follow this fix and I have no idea how to fix it :confused:

Error here:



checking for ld --no-whole-archive... no
configure: error: support for --no-whole-archive is needed


It’d be great if someone could help me fix this.

OS: CentOS release 6.5 (Final)

Thanks