Failed to start game (unknown error)

Every time running RUST in the Steam i have this: “failed to start game (unknown error)”. Legacy works stable, but not new rust. None of the solutions that I found on the internet has no results:

  • disable antivirus
  • Restart steam and restart the computer
  • Verify cache
  • Reinstalling (deleting local files and redownloading all the files)
  • Deleting the files in the steam folder to force an “update”
  • Changing the server location for Steam
    Nothing helps.

What are your system specs? CPU, RAM, video card. You seem to be on XP so it can’t be THAT great, but experimental might still be playable for you.

Also, what is your graphics driver version? (xxx.xx for Nvidia, xx.xx for AMD)

Go into your Steam folder, then steamapps\common\rust_CommonRedist\DirectX\Jun2010 and run DXSETUP.EXE, as well. Reboot, and then try Rust.

If it does not work, I want you to try an additional thing. Go into the Rust folder in Steam (same as above), and double-click on Rust.exe and record what error you get if it does not work. If it doesn’t work and gives an error, please then double-click on RustClient.exe and record any errors if it doesn’t work.

If running RustClient.exe does get Rust to start up to the menu screen, it doesn’t mean the problem is fixed, because you’ll be kicked from servers about 30 seconds after you join unless they have security disabled. Running RustClient.exe instead of Rust.exe bypasses loading EasyAntiCheat, and if you have EAC disabled servers will kick you.

  • AMD Athlon 64 X2 Dual Core 4000+ 2.11GHz, 3GB RAM, NVidia GTX650 1Gb
  • 344.48
  • have no result

Rust.exe is not a valid win32 application

There are no errors. Loading, and everything as you described earlier.

Hi,

If you are getting the error ‘Rust.exe is not a valid win32 application’, then Rust.exe is corrupted or an anti-virus has put it into quarantine silently for some reason.

Try removing Rust.exe, then verifying game local cache in Steam, then launching Rust.exe again to see if the error persists. If it still does the same, please check from your anti-virus’s settings that the file or game folder is not in quarantine/blocked somehow, and possibly add them into AV’s exclusion list.

I tried , but no result. Rust.exe now the same as was before removal. But it looks really like it is damaged , it does not have an icon. Could you make screenshot to show how it should look in the game folder? Or better yet , make md5 test.
b9d8ea49d35d37f68b8748ce62928152 *Rust.exe

Rust requires 4GB of RAM, and especially experimental, so when it does work I don’t know if you’re going to be satisfied, but too little RAM won’t do this.

Open a command prompt as administrator and type the following command:

sfc /scannow

If the system file checker makes you reboot your computer when it’s done, you had corrupt Windows system files somewhere and the checker repaired Windows.

If it doesn’t require you to reboot, I would like you to reboot into Safe Mode with Networking (hit F8 before the Windows loading screen comes up) and then download the free version of MalwareBytes Anti-malware. We don’t need the paid versions for this.

Install it and update its definitions, and then run a full scan.

After MBAM is done, there’s one more thing to do. Download GMER from gmer.net. Choose the randomized file name download option, and then run it. This tool is powerful but all we care about is if the initial scan it does when launched spits out any


RED

lines of text. Let it run for five minutes, and if nothing red comes up, reboot normally and try Rust again.

If red does come up, paste the full contents of the GMER window here, and keep the MBAM log file. Red text in GMER’s startup scan means suspected rootkits.

What antivirus are you running? Your first post in the thread says you disabled it, but what is it?

I just reinstalled windows. The problem was not solved. I use Avira anti-virus.
Why the game runs fine without steam? Probably a problem in this file rust.exe. Maybe it is poorly compatible with windows xp?

Please don’t be indifferent to my problem. Especially, it is not just me. I repeat that we have: a conflict occurs with the file Rust.exe. When running through Steam - "Failed to start the game (unknown error). When you run through a folder - “Rust.exe is Not a valid Win32 application”.

MBAM log: http://www.filedropper.com/mbam
GMER log: http://www.filedropper.com/gmer