fast dl problem

I know that there are like billions of threads like this one but I can’t get my fast dl to work

this is how my current cfg looks like


log            on

hostname        "Techbots Server"
rcon_password        "pass"
sv_password        ""
sv_region        255
sv_lan            0
sv_logbans        0
sv_logecho        0
sv_logfile        1 
sv_log_onefile        0
sv_noclipspeed        5
sv_noclipaccelerate    5
sv_defaultgamemode rpg


sv_downloadurl "http://techbot.bplaced.com/fastdl/"
sv_allowdownload 1
sv_allowupload 1


sbox_allownpcs        1
sbox_godmode        0
sbox_plpldamage        0
sbox_playergod        0
sbox_noclip        1


sbox_maxprops        150
sbox_maxragdolls    5
sbox_maxnpcs        10
sbox_maxballoons    10
sbox_maxeffects        50
sbox_maxdynamite    10
sbox_maxlamps        20
sbox_maxthrusters    30
sbox_maxwheels        20
sbox_maxhoverballs    20
sbox_maxvehicles    6
sbox_maxbuttons        20
sbox_maxsents        20
sbox_maxemitters    5
sbox_maxspawners    3
sbox_maxturrets        2


sv_minrate        0 
sv_maxrate        20000
decalfrequency        10 
sv_maxupdaterate    66 
sv_minupdaterate    10 


// execute ban files
exec banned_ip.cfg 
exec banned_user.cfg 

the folders on the webserver are working too http://techbot.bplaced.com/fastdl/

[editline]29th December 2011[/editline]

No need to hurry. I am going to sleep now. :v:

You need to move the content folders from inside the gamemode to the base directory.

Like LuaMilkshake said, move these folders from gamemodes/rpg/content/


materials
models
particles
sound

to / (Where the “maps” folder is located.

You may also want to set this:
sv_allowdownload 0
sv_allowupload 0

I have that on my server and it works like a charm.

well I’m still getting this

I’ve tried everything

cl_allowdownload and upload are on
cl_downloadfilter is set to all

You need to upload the graphs too. You can find the graphs in your server by going to maps/graphs and you will see the .ain file.

On the FastDL, create a folder in the maps folder called “graphs” and upload the .ain file for the map there.

done

It’s still not working

Accept my steam friend invite. I’ll guide you from there.

You HAVE to have the fastdl in a folder names garrysmod. Change your folder name from fastdl to garrysmod and it will work.

Try using bzip on the maps, then upload to the fastdl server.

I solved this problem already.

It was the hosters fault.

Anyway I’m using dropbox now.