FastDL Broken

I have always had the hardest time getting FastDL to work. And now I am trying again. Here is the portion of the server.cfg that you need to see:



"sv_downloadurl"        ""
"sv_kickerrornum"	"0"


"sv_allowupload"        "1"
"sv_allowdownload"      "1"


I don’t get what’s happening here that is causing it to not work, but it doesn’t download anything for anything that I have on my server.

sv_allowdownload 0

I tried that. It still doesn’t work.

I’d like to mention your FastDL is set up wrong, you do NOT need all of those files. I recommend searching Google for a tutorial of what you do need.

You’re also likely not adding the other files via resource.AddFile to be downloaded.

It is a direct route to all of my server files. Does anyone have the resource.AddFile code for murderthon 9k.

i can see your rcon password :v: you really should link only the files that need to be downloaded… that way exposes all your cfgs and such

I know you can see everything. :smiley: That isn’t what I need help with.

That really should be fixed though, you’re literally posting your ENTIRE server online

How do I private folders? .htaccess isn’t working.

for starters you could point the webserver to a special location with only the files you need to send

symlinks

I moved the folders I need to a different location. However, it still won’t work.

What have you set your download url to?

I won’t paste it. It has maps, materials, models, particles, resource, scripts, and sound. I am not sure if I need particles, resource, and scripts.

I got it to work with this: http://forum.facepunch.com/showthread.php?t=904405

It almost works. However, all of the guns have purple and black checkerboard textures.