FastDL doesn't work!

Hello,
today I setted up FastDL for my Gmod Server.
I followed this tutorial " https://maurits.tv/data/garrysmod/wiki/wiki.garrysmod.com/index70e8.html " except the “the Cache” part.
I realised while testing it, that people that hasn’t subscribed to the materials in the workshop have the typical black-purple texture on some weapons and don’t hear sounds of some weapons.

I hope you can help me!

Did you compress the files? Were you able to confirm that these were downloaded upon joining?

Yes and Yes

Then are you certain that the paths are correct for these materials?

Yeah I’m quite sure about that.

Has this been resolved OP?

Post your fastDL URL please
Did you make a lua script to tell the clients to download from your fastDL?

http://wp12979005.server-he.de/fastdl/

Sure I even made 3 " https://pastebin.com/jikUXc08 " located: 1. /garrysmod/lua/autorun 2. /garrysmod/lua/autorun/server 3. /garrysmod/lua/autorun/client

Remove the trailing / in your fastDL url and it should work.

http://wp12979005.server-he.de/fastdl :dogcited:

Nope still doesn’t work :frowning:

Your resource file should be in lua/autorun/server. Could you post your server.cfg?

[editline]18th October 2017[/editline]

Also, maps should not have resource.AddFile called for them.


hostname "[GER] BulletZone | FastDL | BETA"
sv_password "not needed"
rcon_password "not needed"
ttt_firstpreptime "30"
sv_loadingurl "https://flashstyle.csite.io/loading/bz"
ttt_postround_dm "1"
ttt_traitor_pct "0.34"
ttt_detective_min_players "5"
ttt_firstpreptime "30"
ttt_posttime_seconds "20"
ttt_karma "0"
ttt_det_credits_starting "2"
ttt_credits_starting "3"
ttt_detective_hats "0"
ttt_bots_are_spectators "0"
ttt_round_limit "15"
ttt_time_limit_minutes "60"
ttt_ragdoll_pinning_innocents "1"
ttt_weapon_carrying "1"
ttt_spec_prop_base "1"
csgo_knives_dmg_prim_back "15"
csgo_knives_dmg_prim_front1 "10"
csgo_knives_dmg_prim_front2 "10"
csgo_knives_dmg_sec_back "15"
csgo_knives_dmg_sec_front "10"
sv_downloadurl "http://wp12979005.server-he.de/fastdl"
sv_allowdownload "0"
sv_allowupload "0" 

[editline]18th October 2017[/editline]

the download. lua is now there.

Are you getting any red errors upon joining on the clients console? Normally when the downloads fail it outputs on the console what type of error the web server returns. Does your client even try to download them upon joining?


Requesting 2 lua files from the server
HTTP ERROR 8 downloading http://wp12979005.server-he.de/fastdl/maps/graphs/ttt_minecraft_b5.ain.bz2
HTTP ERROR 8 downloading http://wp12979005.server-he.de/fastdl/maps/graphs/ttt_minecraft_b5.ain
HTTP ERROR 8 downloading http://wp12979005.server-he.de/fastdl/materials/VGUI/ttt/icon_negev.vtf.bz2
HTTP ERROR 8 downloading http://wp12979005.server-he.de/fastdl/materials/VGUI/ttt/icon_negev.vmt.bz2
HTTP ERROR 8 downloading http://wp12979005.server-he.de/fastdl/sound/gronkh/Fail.wav.bz2
HTTP ERROR 8 downloading http://wp12979005.server-he.de/fastdl/sound/gronkh/Fail.wav
HTTP ERROR 8 downloading http://wp12979005.server-he.de/fastdl/materials/VGUI/ttt/bildgronkh.png.bz2
HTTP ERROR 8 downloading http://wp12979005.server-he.de/fastdl/materials/VGUI/ttt/bildgronkh.png
HTTP ERROR 8 downloading http://wp12979005.server-he.de/fastdl/materials/VGUI/ttt/icon_avengeraxe.vtf.bz2
HTTP ERROR 8 downloading http://wp12979005.server-he.de/fastdl/materials/VGUI/ttt/icon_avengeraxe.vmt.bz2
HTTP ERROR 8 downloading http://wp12979005.server-he.de/fastdl/materials/VGUI/ttt/lykrast/icon_cloakingdevice.png.bz2
HTTP ERROR 8 downloading http://wp12979005.server-he.de/fastdl/materials/VGUI/ttt/lykrast/icon_cloakingdevice.png
HTTP ERROR 8 downloading http://wp12979005.server-he.de/fastdl/materials/VGUI/ttt/icon_homing_pigeon.png.bz2
HTTP ERROR 8 downloading http://wp12979005.server-he.de/fastdl/materials/VGUI/ttt/icon_homing_pigeon.png
HTTP ERROR 8 downloading http://wp12979005.server-he.de/fastdl/materials/VGUI/ttt/icon_peacekeeper.vtf.bz2
HTTP ERROR 8 downloading http://wp12979005.server-he.de/fastdl/materials/VGUI/ttt/icon_peacekeeper.vmt.bz2
HTTP ERROR 8 downloading http://wp12979005.server-he.de/fastdl/materials/VGUI/ttt/icon_propexploder.vtf.bz2
HTTP ERROR 8 downloading http://wp12979005.server-he.de/fastdl/materials/VGUI/ttt/icon_propexploder.vmt.bz2
HTTP ERROR 8 downloading http://wp12979005.server-he.de/fastdl/materials/VGUI/ttt/icon_randomat.vtf.bz2
HTTP ERROR 8 downloading http://wp12979005.server-he.de/fastdl/materials/VGUI/ttt/icon_randomat.vmt.bz2
HTTP ERROR 8 downloading http://wp12979005.server-he.de/fastdl/materials/VGUI/ttt/icon_randomtest.vtf.bz2
HTTP ERROR 8 downloading http://wp12979005.server-he.de/fastdl/materials/VGUI/ttt/icon_randomtest.vmt.bz2
PREP OK
material models/weapons/rend_rpg/v_hands has a normal map and an envmapmask.  Must use $normalmapalphaenvmapmask.

Error: Material "models/weapons/w_molotov/molotov" uses unknown shader "vmt"
Error: Material "models/weapons/w_molotov/rag" uses unknown shader "vmt"
KeyValues Error: RecursiveLoadFromBuffer:  got NULL key in file materials/jaanus/shuriken.vmt

Adding Filesystem Addon 'g:\programme\steam\steamapps\common\garrysmod\garrysmod\addons\css_content_addon_apr2016'
	Addon contain game scripts?! Lowering mount priority. (2)
Adding Filesystem Addon 'g:\programme\steam\steamapps\common\garrysmod\garrysmod\addons\css_maps_addon_apr2016'
Initializing Awesomium..
No Kinect SDK
Unknown command "SWAP_TEAMS_EVERY_ROUND"
Unknown command "HUNTER_KILL_BONUS"
Unknown command "HUNTER_FIRE_PENALTY"
Changing gamemode to Trouble in Terrorist Town (terrortown)
'TTT - Defibrillator' is missing Addon, ServerContent, Dupe, Demo or Save tag!
Couldn't retrieve ISteamUGC install info for 247827613!
'TTT Portable Medkit' is missing Addon, ServerContent, Dupe, Demo or Save tag!
Couldn't retrieve ISteamUGC install info for 248977441!
Couldn't retrieve ISteamUGC install info for 308157307!
Couldn't retrieve ISteamUGC install info for 248660099!
Couldn't retrieve ISteamUGC install info for 215998878!
Couldn't retrieve ISteamUGC install info for 275550222!
Couldn't retrieve ISteamUGC install info for 210902773!


this is everything that the console says in red but not every skin that misses, btw not all of my skins misses.

Go to http://wp12979005.server-he.de/fastdl/sound/gronkh/Fail.wav.bz2

You will find out why it doesn’t work.

You just need to click on it one directory before.

“fail” is not the same as “Fail”

I now renamed it but before that it where saved as “fail” not “Fail” now it works, but I don’t know whats up with the rest.

Same thing, the actual files the game tries to download don’t exist on your server.

It exists with the exact same name.

Not really. Enter the link into your browser from the console.