FastDL downloads models but still appears as an ERROR.

I believe FastDL is working like it should now as it downloads when I join the server, but the custom models still appear as errors ingame.

On my FastDL webserver and on my resource.lua, it has maps, models, sounds, resource, materials, and particles.

Webserver: http://trinityrp.x10.mx/gmod-dl/ (Ignore the extra folders)

sv_downloadurl “http://trinityrp.x10.mx/gmod-dl
sv_allowdownload “1”
sv_allowupload “1”

And yes, I also moved all my addons to the appropriate folders on the root.

Edit: The above works now, but I got a new problem, see below!

Make sure when making a resource file you include all the file extensions with the correct paths. This is just an example of what a resource would look like for one model;


if SERVER then
	resource.AddFile("models/player/mafia/male_01.mdl")
	resource.AddFile("models/player/mafia/male_01.dx80.vtx")
	resource.AddFile("models/player/mafia/male_01.dx90.vtx")
	resource.AddFile("models/player/mafia/male_01.xbox.vtx")
	resource.AddFile("models/player/mafia/male_01.vvd")
	resource.AddFile("models/player/mafia/male_01.phy")
	resource.AddFile("models/player/mafia/male_01.sw.vtx")
	resource.AddFile("materials/models/player/mafia/suit.vmt")
	resource.AddFile("materials/models/player/mafia/suit.vtf")
	resource.AddFile("materials/models/player/mafia/eyes.vmt")
	resource.AddFile("materials/models/player/mafia/eyes.vtf")
	resource.AddFile("materials/models/player/mafia/shoes.vmt")
	resource.AddFile("materials/models/player/mafia/shoes.vtf")
end

You basically need to include all the file extensions. I know there are many people who say you only need to include the mdl file or something around those lines, but I like to be sure that the fast download picks up all the file extensions correctly without leaving anything out.

I figured it out myself but thanks, but now I ran into another problem. Apparantly I was using an old resource generator that may skip folders, so I got a new one. In DarkRP the models work and everything, but in the jobs menu they appear as errors?

This is client side, restart your game then join your server again. The models should appear just fine. I have this problem when uploading custom models to my server.

I did that just now, but they are still appearing as errors in the job menu, even though the models still work when I select it.

[editline]25th June 2013[/editline]

Here is some screenshots.

http://puu.sh/3nPvG.jpg
http://puu.sh/3nPwj.jpg

As you see, in jobs they are errors, but when I choose it i am not an error.

Probably a coding mistake in your menu then.

In the shared.lua? I looked at it and everything looks right.

Add my steam and i’ll help you with errors in F4 Menu

DarkRP F4 menu ( Thats the errors basiclly
Ficdy1995

I added you. I wont be able to go on teamviewer so can you just tell me a detailed solution? :slight_smile:

how do you fixed it? i have the same problem