FastDL Help!

So I added some custom traitor menu icons and thy work, but the fastDL isn’t downloading the files.

/gamemodes/terrortown/gamemode/init.lua (bottom) (what i added to the bottom)



resource.AddFile("gamemodes/terrortown/content/materials/vgui/ttt/icon_sword_aug.vmt")
resource.AddFile("gamemodes/terrortown/content/materials/vgui/ttt/icon_sword_awp.vmt")
resource.AddFile("gamemodes/terrortown/content/materials/vgui/ttt/icon_sword_deagle.vmt")
resource.AddFile("gamemodes/terrortown/content/materials/vgui/ttt/icon_sword_famas.vmt")
resource.AddFile("gamemodes/terrortown/content/materials/vgui/ttt/icon_sword_gahlil.vmt")
resource.AddFile("gamemodes/terrortown/content/materials/vgui/ttt/icon_sword_mp7.vmt")
resource.AddFile("gamemodes/terrortown/content/materials/vgui/ttt/icon_sword_p90.vmt")
resource.AddFile("gamemodes/terrortown/content/materials/vgui/ttt/icon_sword_revolver.vmt")
resource.AddFile("gamemodes/terrortown/content/materials/vgui/ttt/icon_sword_sg550.vmt")
resource.AddFile("gamemodes/terrortown/content/materials/vgui/ttt/icon_sword_sg552.vmt")
resource.AddFile("gamemodes/terrortown/content/materials/vgui/ttt/icon_sword_smg.vmt")
resource.AddFile("materials/vgui/ttt/icon_sword_aug.vtf")
resource.AddFile("materials/vgui/ttt/icon_sword_awp.vtf")
resource.AddFile("materials/vgui/ttt/icon_sword_deagle.vtf")
resource.AddFile("materials/vgui/ttt/icon_sword_famas.vtf")
resource.AddFile("materials/vgui/ttt/icon_sword_gahlil.vtf")
resource.AddFile("materials/vgui/ttt/icon_sword_mp7.vtf")
resource.AddFile("materials/vgui/ttt/icon_sword_p90.vtf")
resource.AddFile("materials/vgui/ttt/icon_sword_revolver.vtf")
resource.AddFile("materials/vgui/ttt/icon_sword_sg550.vtf")
resource.AddFile("materials/vgui/ttt/icon_sword_sg552.vtf")
resource.AddFile("materials/vgui/ttt/icon_sword_smg.vtf")


Now it should download the necessary files to each client, but it doesn’t.

i also made all the necessary .bz2 files in the FastDL FTP in the same directories in the ones above.

Plz help, what did i do wrong?

P.S They do work, i physically put the files into my computer gmod folder locations, went on the server and they did work. Its just the FastDL fucking up.

What is your download url