FastDL HTTP Error 1

Hey, attempting to set up a TTT server and trying to get the FastDL to work, have set it up in the server.cfg correctly, to my knowledge:

// Fast-DL
sv_downloadurl "https://fastdl.fadedservers.com/1340/garrysmod/"
sv_allowdownload 0
sv_allowupload 0

The map is correctly uploaded to fastdl, which you can see after opening the FastDL directory on my browser, however upon trying to join in-game I keep getting kicked for “missing map…” and in the console I can see:

HTTP ERROR 1 downloading https://fastdl.fadedservers.com/1340/garrysmod/maps/ttt_rooftops_2016_v1.bsp.bz2
HTTP ERROR 8 downloading https://fastdl.fadedservers.com/1340/garrysmod/maps/ttt_rooftops_2016_v1.bsp
Missing map 'maps/ttt_rooftops_2016_v1.bsp', disconnecting

HTTP ERROR 8 makes sense, since it doesn’t have the uncompressed version, but I cannot figure out what ERROR 1 is or why it’s appearing, since the file is there and everything else is setup correctly(?).

Tried searching the numerous posts I found on the forum, none referenced error 1 but I tried the ‘solutions’ anyway, none of which seemed to help. Also the host automatically compresses the map so I cannot try an uncompressed version.

Your file seems to be corrupted or unreadable (file size equal to 0). All error codes source-sdk-2013/http.h at master · ValveSoftware/source-sdk-2013 · GitHub (starting at 0).