FastDL not working (I know there are many of these but...)

Hi. Yes it’s another “ERHMEHGERDD WAI IT NOO WORK?”
Well i have done a lot of things I have googled so many times and i just can’t for the life of me do this!

I would like to setup a fastdl server.
I have made the server.cfg correctly:



sv_downloadurl "http://denis-gmod.hostzi.com/garrysmod/"
sv_allowdownload "1"
sv_allowupload "1"


I have tried all possible combinations of sv_allowdownload and upload.

I have setup the folders right.
I even added the resource.lua with:



resource.AddFile("maps/rpw_downtown_v3.bsp")


I put it in the root lua folder aswell.

But nothing works.
Every time i start the server with the map i specified it says:



No such map 'maps/rpw_downtown_v3.bsp'


I don’t know whats wrong.
I haven’t put the map in the root map folder. I don’t know if you have to do that.

What is the problem?

[editline]4th March 2013[/editline]

Any help?

Okay I looked at your fast dl its in the right spot is it in your folder on your server exactly like your fastDL? garrysmod/maps/rpw_downtown_v3.bsp?

also you don’t have to do a resource add file for maps. Just sounds materials models etc.

maybe its broken since 159, my fastdl dont work too

Yes. It was and i removed it and tried again.
The differences were that when it was there it threw me this error:



Missing map rpw_downtown_v3.bsp


And yes i do have net_maxfilesize or what ever it’s named to 64.
It’s not over 16 mb either.

Hmm Okay try this use this file on your Fast dl and your server do not bzip it when addeding it just take the file and drop it in to your maps folder on both fast dl and server.

Are you thinking BZIP is the faulty thing here?
I’ll try it now.

But the point of this was to BZIP files…

EDIT: It worked without the file being BZIPPED. But i want it to be BZIPPED, make it compressed and not that large of a file.

[editline]4th March 2013[/editline]

I tried using a different BZIP Compressor and now it gave me:



Couldn't CRC map


[editline]4th March 2013[/editline]

Please anyone help

yeah I thought that might be the problem but add both files the bzip and the regular one thats how it is on my server and it works fine. your running it off of your pc right?

There is an error with bzip files + gmod at the moment, you’re not doing it wrong.

As in, patch 159 (I think) fucked up compressed files downloading.

http://forum.facepunch.com/showthread.php?t=1250354

Okay thanks.
Good to know :slight_smile:

sorry I couldn’t help more dude. thanks pantho