FastDL not working! PLEASE HELP

I have set up a DarkRP recently and yesterday I was trying to get FastDL working.

I put sv_downloadurl “My webhost ftp”
into the server.cfg.

It seemed to working but when I tried to test it out by deleting the map “rp_downtown_v2” from my Gmod folder(This is the map the server is playing) and connecting to the server it took about 20-30mins to download the map, which is 8mb (I have done the .bz2 to it) Imo this is not quite a fast download at all, obviously. I have put the folder inside public_html in the webhost FTP.

I’m using x10hosting as my webhost. Any help would be greatly appreciated.

My server.cfg:

// server name
hostname “myhostname”

// rcon passsword

rcon_password “mypassword”

// server cvars
mp_friendlyfire 1
mp_footsteps 1
mp_autoteambalance 1
mp_autokick 0
mp_flashlight 1
mp_tkpunish 1
mp_forcecamera 0
sv_alltalk 0
sv_pausable 0
sv_cheats 0
sv_consistency 0
sv_allowupload 1
sv_allowdownload 1
sv_maxspeed 320
mp_limitteams 10
mp_hostagepenalty 10
sv_voiceenable 1
mp_allowspectators 1
mp_timelimit 25
mp_chattime 10
sv_timeout 120
sv_downloadurl “My webhost FTP:/”
net_maxfilesize 64

// round specific cvars
mp_freezetime 6
mp_roundtime 5
mp_startmoney 800
mp_c4timer 45
mp_fraglimit 0
mp_maxrounds 0
mp_winlimit 0
mp_playerid 0
mp_spawnprotectiontime 5

// bandwidth rates/settings
sv_minrate 5000
sv_maxrate 9999
decalfrequency 10
sv_maxupdaterate 30
sv_minupdaterate 13
net_maxfilesize 64

// server logging
log off
sv_logbans 0
sv_logecho 1
sv_logfile 1
sv_log_onefile 0

// operation
sv_lan 0
sv_region 255

// execute ban files
exec banned_user.cfg
exec banned_ip.cfg

Bump! Need help, loads of people quit while joining my seever, really losing out on players

Set sv_allowdownload and sv_allowupload to 0. That works for me.

make sure your map is under garrysmod/maps on your web server and that you have sv_downloadurl set to “(your webhost)/garrysmod”

I think I know why,

This is my sv_downloadurl :

sv_downloadurl “ftp://gmodfile@gmodfiles.x10.mx/public_html/gmod-dl/

As you can see it says “ftp” not “http”

I got the URL from my Filezilla by right clicking on the folder garrysmod and copying URL.

My question is how do I get a http of these files?

http://gmodfiles.x10.mx/gmod-dl/

The link above is your web space, try using that and see if it works.

One thing I’ve noticed, you have alot of unneeded files uploaded. Only upload files needed by the clients, for example all of us have PHX props now so there is no reason to upload them, same goes for any addons that do not force any files to be sent, you won’t have to upload them unless you include them in a resource script. Take a look at the sv_downoadurl wiki article, may clear up a few things about which files are needed vs which ones are not.

Also uploading lua files from an addon is not needed as any lua the client needs is sent via the Lua Cache file.

Hope this helps some, be sure sv_allowdownload is set to 0 as well.

Thank you got it working =D

irishmadboy, x10hosting.com does not allow file hosting for stuffs that is not for your website. You will get suspended very soon.